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Chapter 1 - Overview 
The Horizontal XSection software was created, designed, and coded by a well-site geologisti, for geologists, engineers 
and technicians who are looking for more comprehensive software on their horizontal projects. This manual has been 
updated in 2016 to reflect a new improved geosteering tool. 
Survey Data – The Heart of the Program 
The most important visual component of the Horizontal XSection is the Cross-Section track, which is organized around 
the survey data. Horizontal XSection utilizes the "Minimum Curvature Method" to calculate the True Vertical Depth, as 
well as the other derived survey information (Vertical Section, NS or Northings, EW or Eastings, Doglegs - see "Chapter 5 
- Survey Data" for more information). Moreover, the software interpolates the borehole azimuth and inclination for 
every foot between surveys, and calculates the related survey parameters (TVD, VS, Northings, etc.). The below figure 
shows a portion of a log showing the “build” section of a horizontal well; the red sections are slides while the blue is 
when they were rotating. The green dots are the surveys. 

  
Besides calculating the survey data parameters, the Horizontal XSection Log software allows for easy access to the 
survey data. The calculated survey values are stored in the programs memory and are constantly displayed relative to 
the position of the mouse pointer. For example, in the below example, the mouse is at 3742.0’ MD and displays all the 
relevant survey data in the status bar at the bottom of the window. If there are two or more laterals displayed at the 
same measured depth, for example, a well plan or a sidetrack, the software will determine which curve is closer to the 
mouse pointer, and display only that lateral's survey information. If you move the mouse directly over a survey point, 
the annotation in the status bar will indicate that this is a survey point. When there is no mention of a survey point (as in 
the below example), the status bar displays calculated (interpolated) survey parameters for measured depths that occur 
between survey points. 
The other tracks consist of four graphs for the ROP, TG and or GC data, Gamma or other LWD data, a sample track to 
hold the sample components, and three histogram tracks that can be used for a variety of purposes like porosity, flare 
length, show quality, grain size, cleating, or any information that is best displayed by a histogram. Most of the editing of 
the log will occur in the cross-section track. The log is formatted using the formatting menus. Use the histogram tracks 



to display information 

 
To annotate the log, the user selects the appropriate log mode, for example "Text" mode to add text, "Lithology" mode 
to add lithology beds, "Line" mode to draw lines, "Image" mode to add images and pictures, "TVD Log" mode to add TVD 
log data to your cross-section. There is also a “Geo-Horizon” mode that allows the user to add geologic information that 
can be projected on to a “TVD versus Vertical Section” Cross-Section (See Chapter 11).  
The following chapters delve into more detail the different features of this software program. Read the whole manual to 
learn about many of the software features, as well as shortcuts and tips.  
Quick Reference (The Different Program Modes) 
Lithology Mode (Cross-Section Track): 

 Left-click mouse and hold to draw lithology bed. 
 Left-click mouse once to draw lithology stringer. 
 Hold ctrl-key down and left-click lithology bed to delete. 
 Hold shift-key down and left-click lithology bed to MoveToBack. 
 Move mouse over lithology bed and right-click mouse for editing menu. 
 Move mouse over lithology beds while shift key depressed to group lithology beds together, then right-click mouse for editing menu. This will allow for multiple beds to be moved, resized and copy and pasted. 

Text Mode (Cross-Section Track, Graph Tracks): 
 Left-click mouse to open Text Editor (cross-section track, graph tracks). 
 Left-click mouse over a text block (block should have an orange outline) to open the text editor with selected text pre-loaded. 
 Hold shift-key down and left-mouse click mouse to open text editor with survey data in status bar loaded and formatted. 
 Move mouse over text block and right-click mouse for editing menu. 

Draw Line Mode (Cross-Section Track): 
 Left click mouse and hold to draw line. 
 Move mouse over the end of a line (orange-rectangle should appear), left-click mouse and hold to move selected line. 
 Move mouse over end of line (either end) and right-click mouse for editing menu – including dip calculation. 

Add Image Mode (Cross-Section Track): 
 Left click mouse to add the 'selected' image.  
 Select Image from the menu bar Mode->Add Image-> 'Select an Image' 
 Move mouse over an image (orange bounding rectangle will appear) and right-click mouse to open the editing menu .  



TVD Log Mode (Cross-Section Track) 
The "TVD Log" mode is used to enter, move, change the opacity, and change the depths from TVD to Subsea, of logs in 
the cross-section track. There must be at least one TVD Log loaded into the TVD Menu for the user to enter "TVD Log" 
mode. 
Move the mouse over a log image (orange bounding rectangle will appear) and right-click for the editing menu.  
See "Chapter 10 - TVD Logs in the Cross-Section", for more information. 
Geo-horizon Mode (Cross-Section Track) 
Use this mode to draw geologic features onto the cross-section that can then be projected onto the “TVD vs. Vertical 
Section” View (See Chapter 11, which is about the Geo-horizon feature). 
Save 
 Save often and backup files regularly and/or enable the AutoSave function. More on saving and backing up logs in the "Chapter 3 - The Formatting and File Menu". 
The ToolBar Buttons 
The toolbar allows for quick access to many of the features described in subsequent chapters. The below illustration 
explains what the different buttons on the toolbar do.  

 

 
  



Chapter 2 - Getting Started 
Entering Survey Data 
The heart of this program is the survey data and the ability for this program to compute the derived survey parameters.  
Start the XSection Horizontal Log Program.  
Begin by clicking on the menu bar item Data Entry/Editors ->Survey Data Editors->Well Plan…. 

 This will open up the Survey Data Sheet for the Well Plan curve. 

 
Select the "Edit/Add Tie-In Survey" button and enter "1000" in the "MD" field, "180" in the "AZ" field and "1000" in the 
"TVD" field, leave everything else as zeros and make sure the "Direction" field is set to"180" (see above).  



Note: when entering Tie-in Values, all the fields must be filled. If the Tie-In value is an existing survey, you enter all the 
fields in the tie-in value window from the tie-in survey. In order for the program to accurately calculate the vertical 
section (VS), the "Direction" field must be correctly set (the Directional Driller will have this information). See "Chapter 5 
- Survey Data", for more information regarding the derived survey data. After the tie-in value are entered for a particular 
lateral, only the MD, AZ and INC need be entered, the Horizontal XSection Log software will calculate the other survey 
fields .  
Now click on the Add Survey button and enter "1350" for Measured Depth (MD), "89.5" for Inclination (INC) and "180" 
for azimuth (AZ), and click the "Done" button. Click "Add Survey" again and enter "2000" (MD), "89.5" (INC) and "180" 
(AZ) and click the "Done" button. Now go to the right side of the editor and type "1000" in the "Slide From" text box and 
"1350" in the "Slide To" text box and click the "Add Slide Interval" button. Now click the "Done" button to exit the Well 
Plan Survey Data Sheet window. The Horizontal XSection program will draw a well plan curve that goes from vertical to 
horizontal with 25.57 degree doglegs. Green markers are shown at  

 
the survey points. The line is red during sliding intervals, and black during rotating intervals. Notice the survey data 
shown on the status bar at the bottom of the window as you move the mouse along the planned well curve. At survey 
points, the survey data and parameters will be annotated with the words "Survey Point", as in the example above. 
Between the survey points the survey data is interpolated and there is no "Survey Point" annotation.  
Editing Lateral Curve Attributes 
Click the menu item Formatting->Format Lateral Curve Attributes…, to open the "Edit Lateral Line Attributes" window. 
Select the "Well Plan" lateral from the list on the right side of the window, and all the attributes for this curve will 
appear in the "Styles" section. Change the line style from "Solid" to "Dash", and make any other changes to the style of 
the well plan curve. Notice you can even change the name of the lateral, for example type in Well Plan #1, and click 
change name. This will change the name of the lateral on the logs legend when the log is printed, as well as in the Survey 
Data Editor menu, the plan view and on the TVD versus Vertical Section view (see later chapters). Click "Done" when you 
are finished making changes.  
Lithology Mode and Drawing Lithology Beds 
There are six modes for editing your log: "Lithology" mode, "Text" mode, "Draw Line" mode, "Add Image" mode, "TVD 
Log" mode and “Geo-Horizon” mode.  



 
For the lithology mode, simply click the menu item 
Mode->Lithology-> and select any of the 20 Lithology 
patterns, alternately, select a lithology from the toolbar. 
The cursor will change to a cross. Left click and hold, 
move the mouse to draw your bed, release the mouse 

when done drawing. To add a stringer to your log, just click once without moving the mouse, and a stringer will appear 
at the click point. Use the menu item Mode->Lithology->Set Stringer Size… to change the default stringer dimensions. 

 
An orange border will appear when the mouse cross hovers over a particular lithology element (bed or stringer). When 
you see the orange border, right click to "Move", "Delete", "MoveToBack", "Rotate" or "Copy" the selected element. A 
delete lithology bed shortcut is to left click a bed while holding down the "Ctrl" key. Similarly, hold down the "shift" key 
while left-clicking a lithology bed to move the selected lithology bed to the back (MoveToBack function). 
Text Mode and Adding Text to your Log 
Text can be added to the cross-section track, the graph tracks and the sample % track. 
Click the menu item Mode->Text, or select the Text Symbol  from the toolbar. Click on the log where you want to add 
text and a Text Editor window will appear. The text editor window is very simple and self-explanatory. To select text that 
is already on the log, just click on the selected text in Text Mode, and the text editor will appear with the selected text 
loaded into the Text Editor. 



 
When in "Text" mode, an orange border will appear when the mouse arrow moves over a text element, or within 10 
pixels (about a 10th of an inch) of the end of a pointer line associated with a text element. Right click to "Move" "Resize" 
or "Delete" a text element. A pointer line can only be moved. Open the text editor to deselect the pointer or bounding 
rectangle check boxes to make them disappear. 
Adding Formatted Surveys as Text to your Log 
To add formatted survey data to your log, while in "Text Mode" move the cursor to the desired point on the lateral, hold 
down the shift key and left-click the mouse. This will load the survey data that is in the status bar at the bottom of the 
window into the Text Editor. 

 
To make the survey data easier to read for the viewer, choose a monospaced font, for example “Courier New”. 



 
  
Note, if a client computer does not have the font that you selected, a default font will be substituted - usually this 
font will be "Microsoft Sans Serif". This may result in a log that looks different on your client's computer than on your 
computer. One way to avoid this problem is to select common fonts like Arial, Times New Roman, Courier New and 
Consolas. 
How to Quickly Change Text parameters (Fonts, Font Size, Font Color and Font Background Color) 
For organizational purposes, it is a good idea to use the same text parameters (font, font size, font color and background 
color) for text added for similar purposes. For example use one set of text parameters for sample descriptions, another 
for drilling parameters. A recent change to the text editor now allows the geologist / user to preset the F2 through F8 
Keys to any text style (font type, font size, font color and background color). With the text editor open the user can 
depress any of the F2 through F8 to load the preset text style.  Use the “Set F Keys” buttons to set F2 – F8 to the loaded 
font style. F key preset styles are saved to the laptop, so that any new font style set to any F key is remembered by the 
program between user sessions. 
Adding Text to the Sample % Track 
Because left-mouse clicking on the sample % track opens the sample % editor, even in text mode, adding text to this 
track is slightly different than to the other tracks. To add or edit text in the Sample % track, the program must be in 
"Text" Mode and the user must have the Control (Ctrl) key depressed when depressing the left mouse key! The 
Control (Ctrl) key must also be depressed to move, resize or delete text blocks in the Sample % track! 
Draw Line Mode and Adding a Line to your Log 
Click the menu item Mode->Add Image, or click the  icon on the toolbar. Click and hold the left-button on the mouse 
to start drawing your line. Release the left mouse button when done drawing. To move a line, position the mouse arrow 
over either end of the line until the small orange rectangle appears. Then left click and hold while moving the mouse.  

 
Release the left-mouse button when finished repositioning the line. To 
delete a line, first position the mouse over either end of a line until the 
orange rectangle appears. Then right-click the mouse and select 
"Delete". Another method of deleting a line is simply to resize the line to 
less than 1/2 inch. 



Note, the steps for drawing and moving a line in "Draw Line" mode are different than the steps for moving a pointer 
line connected to a text block in "Text" Mode. 
 

 
Calculating Apparent Dip Using the Draw Line Feature 
The "Draw Line" mode of the Horizontal XSection has a "Calculate Dip" tool that will calculate the apparent dip of the 
line based on the change in TVD of the line and the distance between the beginning of the line and the end of the line.To 
access this feature, simply draw a line where you want to measure the dip. Then right-click the mouse over either end of 
the line and select the "Calculate Dip" from the popup menu as show below. Note: the line in question is drawn between 
the bottom of the coal seam connecting the two TVD Logs. 

 
The apparent dip calculator will calculate a value based on the difference in measured depth and TVD (or SS) for the line 
that was drawn. However, this could be an inaccurate value for a borehole trajectory that is not near 90° Inclination, or 
is turning. The program will also project the apparent dip using the vertical section values for any laterals that are 
present for the whole length of the drawn line. In the above example, the apparent dip is calculated using the measured 
depth of the line as well as the vertical section for similar depths for the "Well Plan" and "Lateral #1". Surprisingly, the 
values diverge by over 1°.  
The apparent dip calculator will calculate a value based on the difference in measured depth and TVD (or SS) for the line 
that was drawn. However, this could be an inaccurate value for a borehole trajectory that is not near 90° Inclination, or 
is turning. The program will also project the apparent dip using the vertical section values for any laterals that are 
present for the whole length of the drawn line. In the above example, the apparent dip is calculated using the measured 
depth of the line as well as the vertical section for similar depths for the "Well Plan" and "Lateral #1". Surprisingly, the 
values diverge by over 1°.  



 
Or, use the "Dip Calculator" in the tools menu as an 
alternate method to determine an apparent dip. 
Add Image Mode and Adding Images to your 
Log 
Click the menu item Mode->Add Image->select any of 
the images in the list, or click the icon on the 
toolbar. The toolbar holds the last image selected 
from the Add Image menu. Left click anywhere on the 
cross-section track to add your image. Right click over 

the image to delete or move the image. There is more on images in "Chapter 7 - Log Images and Photos". 
TVD Log Mode 
The TVD Log mode is used for adding Log curves to the cross-section track. These logs can be from pilot hole wire-line 
logs, TVD logs generated while drilling the curve, or offset logs from nearby wells, and is an essential tool in geo-steering 
your horizontal well. 
Click the menu item Mode->TVD Log ->select any of the logs in the list, or click the  icon on the toolbar. If there are no 
logs loaded in the menu item, the user will not be able to select "TVD Log" mode. This is true, even if there are log 
images on the cross-section.  
Much more can be learned in Chapter 10 - "TVD Logs in the Cross-Section". 
Note: occasionally when a log file is first opened by double clicking on a file, the TVD logs will be missing from the list 
in the TVD Log menu. Open and close the "Cross-Section TVD Log Editor" (Data Entry/Editors->Cross-Section TVD Log 
Editor… menu) to list the TVD logs. 

Zooming 
The graphic on the left shows the location of a drop 
down menu on the far right of the toolbar. Simply select 
the degree of magnification that you desire and the log 
will automatically scale and redraw. The default 
magnification is 100%. Note however, that all elements 
will automatically move and be scaled to the new 
magnification, with the exception of Log Images and 
Photos that are added to the log. Because of issues with 
pixilation, there is no scaling of photos or Log Images. 
For example, a two- inch square photo added to the log 

remains 2-inch square regardless of the degree of zooming. However, pointer lines attached to a log image or photo will 
be scaled and shifted correctly! 
 
  



Chapter 3 - The File and Formatting Menus 
The "File" menu holds many of the menu items found in all windows programs. The "Format" menu allows the user to 
easily and quickly format their log in a variety of ways. The following chapter discusses some of these features. 

 
The File Menu 
Open and New 
The File->Open selection will open a saved file. Use the File->New (existing log as template)… option to begin a new file 
with the same file formatting as the file presently open.  
Cover Page 
Select File->Cover Page… from the Menu Bar to open the Title Page Editor.  
This editor is used to fill in the title or cover page header that begins every log (see below image) Click the "Import 
Header File" button to load a template cover page, or use the "Export Header File" button to save a template cover 
page. Drag and drop an image to the upper left-hand corner image box with your company logo or any image file (JPEG, 
TIFF, BITMAP, PNG, GIF, etc…) that you desire. Images that are larger than 5" x 3" will automatically be resized to fit, and 
print in the upper left-hand corner of the title page.  
Click on the "Notes" button to open the edit notes window. This is the lower right-hand corner area (red circle) of the 
title page, and is a blank area that can be used for many purposes. For example casing data, or mud data or a short well 
synopsis can be entered in this area (see below). 



 
  Notes Editor      Cover Page 

  
Auto Save Features 
Select File->Auto Save Features… from the menu bar to open the “Automatic and Backup Saving Features” window. 

  
There are two features: Automatic Backup and Automatic Save.  
Automatic Backup File Feature 
By default, the "Automatic Backup File Feature" is enabled whenever you start 
a new Horizontal XSection session. The "Automatic Backup File Feature" will 
create a folder called "XSectionBackup" in the same folder that you are saving 

your Horizontal XSection Log file. The "XSectionBackup" folder will contain a backup version (*.hxl) of the file that you 



are working on. This file will be called "BACKUP + file name". For example, if you create a new XSection file called 
"Lateral1" and save it to "My Documents", the Horizontal XSection Log will create a folder called "XSectionBackup" in 
"My documents" and create a backup of your lateral1 file named "BACKUPLateral1".  
Moreover, the backup file will be updated after changes are made to your file. If the program or the computer crashes, 
the backup file will be the most up-to-date file. If you remove either the" XSectionBackup" folder or the "BACKUP + 
filename" file, the Horizontal XSection program will create a new folder and/or file. This creates a handy way of backing 
up your files. The process is to move either the backup file or the XSectionBackup folder to a removable drive, and the 
Horizontal XSection software will create a new one in its place.  
If you use one of the BACKUP files to recover a session, quickly rename the file and move its location. Otherwise 
XSection will create a new XSectionBackup folder in the old XSectionBackup folder with the name BACKUP + filename + 
Backup + filename. This can become confusing fast. The work around is to quickly rename the file in a new location as 
soon as you open the backup file. 
Automatic Save Feature 
The Automatic Save Feature is slightly different. This option, by default, is not enabled when you begin a new XSection 
session. The Automatic Save Feature, when enabled, saves your file before you make new changes to your log. For 
example, if your file is named "lateral1" and located in the "my documents" folder, and you select the "Text" editing 
Mode after just entering lithology beds using the "Lithology" editing mode, XSection will save the "lateral1" file without 
the user being prompted.  
The automatic save feature, when enabled, automatically saves your file whenever you: change editing Modes (i.e. select either Lithology, Text, Add Image, Draw Line, or TVD Log), open the Survey Editor for any lateral, open the Graph Editor for any graph tracks, open the Histogram editor for any of the histogram tracks open any of the formatting menu items, open the "Log Depths…" menu item, open the Log Scale…" menu item, open the Format Lateral Curve Attributes… menu item, open the "Track Positions…" menu item. 
 
Page Setup and Printing 
These menu items are discussed in the Chapter on printing (Chapter 8) 
Export Log as Image (JPEG, TIFF, BMP....) 
The "Export Log as Image (JPEG, TIFF, BMP....) " menu item allows the user to export a complete log (with title page and 
legend) as either a JPEG, TIFF, BITMAP, GIFF or PNG file. Each of the these file types have their advantages, which are 
listed below, file sizes are for average logs: 
JPEG - easily uploaded by photo processing software, ~ 2 MB fileii. TIFF - common oil field file type, high quality graphics usually over 2 MB fileiii. BITMAP - A great way to fill up your hard drive (euphemism for very large files ~50 MB fileiv). GIFF - small files (usually under 1 MB filev), low quality, web browser friendly. PNG - web browser friendly, high quality, ~2mb filevi - use this file format to send to your clients if file size is not an issue.  
Export Curve Data as LAS File (*.las)… 
The “Export Curve Data as LAS File (*.las)…” menu item saves all the curve data in all the graphs as a LAS file. Presently, 
data is saved in LAS 2.0 file format. 



The Format Menu 
Log Formatting 
Click on Formatting->Log Depths…, Formatting->Log Scales…, or Formatting->Track Positions… to set the log depths, the 
log scales or the track positions, respectively.  
Formatting Menus 
Each track has its own formatting window, and all follow a similar layout. For example, the below screen example is the format menu for “linear-type” Graph #2 (Formatting->Graph 2 Track->Formatting…). If the graph is set for semi-log, the formatting window looks slightly different.  The format window allows the user to enable or disable the track 

(except the cross-section track which cannot be disabled), set the 
vertical lines, set the horizontal divisions, and set the height 
dimension. The format window also keeps track of the total log 
height in inches, and turns red if the total height exceeds 8". This 
indicates that the total height is too large for landscape printing on 
11" x 8.5" inch paper. Note the program will not stop the user from 
setting a height dimension that is over 8”, rather the red is a 
warning to indicate possible printing problems. 
Histogram Format Menu 
The Histogram Formatting menu has a few added features that 
differentiate it from the other format menus. These added features 
are a "Histogram Name" section, a “Scale” drop down menu, a 

“Divisions” drop down menu, a "Value Properties" section a "Which Way is Up" check box (see below example), and a 
“Factors” section.  
Histogram Name 
This section names the Histogram track. For example if you want the Histogram track to be used for porosity, type in 
"Porosity". Alternately, you could also use the histogram for cleating, grain size, rounding, flare length, directional driller 
ego size, etc. The name the user gives the histogram will be displayed on the histogram track when the log is printed. 
Value versus Factor Mode 
Simply, if the “Factor” text box is set to the value “-999”, the histogram is in values mode and will have the values shown 
in the displayed values text box. Otherwise, the histogram will have a scale dependent on the “Scale” drop down menu 
value multiplied by the “Factor” value. In value mode, the scale drop-down menu is ignored, similarly, in factor mode, 
the “Displayed Values” values are ignored. 
Chapter 9 goes into more detail about the difference between value and factor mode and the histogram 
track in general. 
 



 
Which Way is Up  
This section of the histogram format window sets the direction the histogram will be drawn. Normal (the default setting) 
draws the histogram bottom to top. Check reverse and the program draws the histogram top to bottom. 
    Normal    Reverse 

 
The Graph Tracks 
The graph tracks also have the additional menu item that allows the user to select either a linear or semi-logarithmic 
format.  

 
See "Chapter 4 - Graph Data” for more information on both linear and the semi-log formats and how to edit their 
corresponding scales using the "Graph Data Editors" under the "Data Entry/Editors" main-menu item.  
Formatting the Cross-Section TVD Scales 
From the menu bar, click Formatting->Cross-Section Track->Edit TVD Scales… to open the “Set TVD Scales” window. Each 
scale has three parts: The measured depth (MD) where the scale change begins, the TVD for the top of the scale, and the 
vertical TVD Scale.  



 
These three parameters are set by the user. The vertical TVD scale is limited to the following selections: 50', 100', 200', 
300', 400', 500', 1000', 2000', 3000', or 5000'. The TVD for the bottom of the scale is the TVD top + the vertical TVD scale. 
For example, the highlighted scale change, in the below example, shows a scale change occurring at 4400' MD, with the 
top of cross-section being at 2900' TVD and a 50' vertical TVD scale. Though it is not shown, this would put the bottom 
of the scale at 2950' TVD.  
 
When you load the Horizontal XSection program, it begins with a default TVD scale of 500', set at 1000' MD with the TVD 
top scale set at 1000' TVD. There must always be at least one scale for the cross-section, and the first scale cannot be 
deleted. To change a scale, select the scale from the list of scales on the left, change the TVD Top Depth or the Vertical 
TVD Scale by choosing the appropriate radio button, and click the “Add or Change Scale” button. To create a new scale, 
type in a measured depth value in the text box labeled “Scale at MD” that does not exist in the list of scales. Then 
choose a TVD top value and a vertical scale value, and click the “Add or Change Scale” button. To delete a scale, simply 
select the scale from the list and click the “Delete” button.  
Tip: Do not set a new scale right before or right after a 100' interval (i.e. 2195' MD or 2205' MD), this will result in 
overlap between the new scale text and the MD text values that occur every 100'. It is fine to set a new scale at a 100' 
interval (i.e. 2100' MD). Other safe values are to set the scale at 50' (i.e. 2150' MD). 
 

 
The Effects of Adding a New TVD Scale 
If you create a new TVD scale, or change an 
existing scale, all text blocks, lines, images, TVD 
logs, and lithology beds in the area of the new 
scale, will be affected. However, changes in 
scales affect objects differently. For example, 
lithology beds as well as TVD logs, are 
dependent on the vertical scale of the TVD 
scale. If you change the vertical scale of a TVD 
scale from 200' to 100' (see below picture), all 
lithology beds in the new scale area will become 
twice as large. Moreover, lines will move in 
relation to the new scale. Images and text will 
move their position, but their size will remain 
the same. The location of all elements is 
dependent on the position of the upper left 
corner of each element. A scale change to the 
right of the left-hand corner of an object will 
not move or affect that object.  The below 

example shows what happens to different objects when the vertical TVD scale is changed from 200' to 100'. Notice the 
anhydrite (orange) lithology bed is not affected by the scale change because the left-hand corner of the element is to 
the left of the scale.  



Before Scale Change      After Scale Change 

 
A common occurrence when adding or changing scales is to move, either on purpose or accidentally, elements out of 
the viewing area (i.e. the sandstone and accompanying text above). The elements still exist in computer memory but are 
no longer visible. Change the scale back and the elements will appear again. It does not hurt anything, other than taking 
up memory, to have elements that are not visible, but if you feel the need to delete elements that are no longer visible, 
use the "Clean-Up Log Utility" in the Tool menu. This utility will delete all elements that are wholly and some elements 
that are partly out of the viewing area. The same is true if you shorten the log length (Formatting->Log Depths…). 
Format Lateral Curve Attributes 
Use this menu item too format the lateral curve attributes like line, width, rotate color, slide colors, etc. This menu items 
is described in more detail in the Chapter "Getting Started" (Chapter 2), and anyway, is self-explanatory. 
 
  



Chapter 4 - Graph Data (ROP, Total Gas, Gamma, etc…) 
Horizontal XSection has four tracks, labeled Graph #1, Graph #2, Graph #3 and Graph #4, which are devoted to 
exhibiting data in a graph format. Usually this is drilling data, gas data, or MWD data. There are numerous ways to enter 
and edit the data. 
The Graph Editor 
There are two methods to open the graph editor. The first is to click the menu item (on the main menu bar) Data 
Entry/Editors->Graph Data Editors->Graph 1… , Graph 2…, Graph3…, or Graph 4…, depending on which graph you want 
to edit. The other method is to click on the graph tool bar image (circled in Red in the below screen example) for the 
corresponding graph, 1 for graph one, 2 for graph two, etc. 

  
The graph editor is divided into two Sections: The top section is called "Edit Curve Attributes", while the bottom section 
is called "Import / Export Graph Data". 

 
The "Edit Curve Attributes" takes up most of the 
window and is where the Curve Name, Curve Style, 
Curve Scales and Curve Units can be edited and the 
curve data deleted or edited.  
The first step is to choose one of the 10 curves 
(updated from 6 in version 2.0) from the "Select Curve 
to Edit" list that is at the upper right of the window. 
When a curve is selected, the characteristics of that 
curve are displayed in the different parts of the "Edit 
Curve Attributes" section. Use the drop-down lists in 
the "Line Style" section to change the line 
characteristics. To change the Curve name, Graph Units 
or the Curve Scales, type the new values in the text 
areas and click the corresponding "Change…" button 
for the changes to take effect. To delete the curve data, 
select the curve and click the "Delete" button. 
Similarly, to edit curve data, select the curve and click 
the "Edit Numeric Data" button. 
Editing Curve Data 
Most graph data will be imported to the log either as 
text files or from *.las files. But there are instances 
where it is advantageous to edit or enter data directing 

using the Horizontal XSection editing features. 
Select a curve to edit and click the "Edit Numeric Data" button to open the "Edit Curve Data" window (shown below). 



 
The title of the window will be the name of 
the curves whose data is being edited. Use 
the data table on the left and edit the data 
as desired. The right-hand part of the 
window has features to help with editing 
the data. The insert button will add a row 
below the highlighted or active cell, with a 
MD value of one foot greater than the 
highlighted cell, and a datum value that is 
set in the "Datum Value:" text area. The 
"Delete Row" button will delete the row of 
the highlighted or active cell. The "Check 
Sorting" button checks for out-of-order 
values in the MD Column. The "Delete 
Rows" button will delete all rows with a 
value in the "Datum" column equal to the 
value set by the user in the text area below 
the "Delete Rows" button. Similarly, the 
"Replace" button will replace every value in 
the datum column, set by the user, with the 
replacement value, also set by the user. This 
is useful when you are importing LAS files 
received from a directional drilling 
company.  Often times the LAS file will have 
a "-999.00" or "-999.25" for missing or bad 

data. Use the above utilities to quickly delete or replace these bad values. 
Import Graph Data 
Usually, graph data will be imported. The Horizontal XSection can accept 3 types of files: text files (*.txt) - either tab or 
space, comma separated files (*.csv), and LAS files(*.las). 
Each of the different file types has their advantages. Text files are easy to create and can be edited in Windows Notepad. 
Comma separated files, are a type of text file that can easily be open by Microsoft Excel bypassing the "Text Import 
Wizard". If you are going to do a lot of editing of data using Microsoft Excel I suggest saving files in this format. Finally, 
LAS (*.las) files are ubiquitous in the oil patch. Usually these will be files given to you by a third-party vender, like a 
WMD, Directional Driller or a download from an EDR.  
To import data files for either graph track, open the graph editor as outlined above and click the "Import Graph Data 
File" button at the bottom in the "Import / Export Graph Data" section. Select the file type you wish to import (as shown 
in the screenshot example).  



 
After a file is selected, a "Graph Import" window will appear that has drop-menus for each graph curve. The program 
assumes that the MD will be column number 1, though the user can change the MD column. It also displays the first and 
last value for the column the user chooses for the MD (Depth). For the other curves, the user needs to choose from the 
available columns in the drop down menu. This means that the user must know what column is for which curve before 
importing a text or a comma separated value file. When the appropriate columns have been chosen for the correct 
curves, click the "Load File" button. Once columns are selected for a particular graph track, the "Graph Import" window 
will remember the columns selected for each curve from the previous file upload session.   

One advantage of importing LAS files is that the columns are 
delineated with a name that usually describes the data in the 
file.  
Overwriting Data 
When data is loaded for a curve that already has data, the 
loading file will overwrite and delete any data after the first 
measured depth of the loaded file. For example, if you have 
ROP data from 1000' to 2000' MD and load a ROP data file that 
begins at 1900' MD and goes to 3000' MD, the loading file will 
overwrite the data from 1900' MD to 2000' MD. After loading 
this ROP data file, the ROP curve will have data that goes from 
1000' MD to 3000' MD. However, if you were to then load an 
ROP file that goes from 2500' MD to 2600' MD, the program 
would overwrite the data from 2500' MD to  
2600' MD and delete all the data from 2600' MD to 3000' MD. 
Hence, the curve would now have data that goes from 1000' 
MD to 2600' MD. The purpose behind this is to make it easy to 
add sidetrack data to an existing curve file, without having to 
delete any data by hand. 
All Depths / Some Depths 
The import editor also gives the user the ability to upload all 
the data from a given file, or by selecting the “Some Depths” 

radio button, selected depths for importing. 



 
Out-Of-Order-Depths 
By default, the program will reject a file that has its MD out 
of order, unless the user un-clicks the "Rejects upload if out-
of-order depths" check box in the "Graph Editor" window 
before loading a file. In which case, the program will load 
the file no matter the order of the MD column - this may 
result in a less-than-desirable graph. However, it is a simple 

process to use the "Check Order" button and the "Delete Button" in the "Edit Curve Data" window, discussed earlier, to 
quickly clean up any out-of-order data. 
Linear or Semi-Log Scales 
The graph tracks can employ either linear or semi-logarithmic scales. The selection is made using the formatting menu 
(See Chapter 2). The linear scale option allows for more customization of the log scale. Each curve may have a different 
scale, and scales can be changed numerous times for each curve. Moreover, top and bottom values can be changed and 
curve wrap can be enabled or disabled. 
 A graph with a semi-log scale has fewer options. The semi-log scale is useful for displaying curves with a wide range of 
values. Most often, a semi-logarithmic scale is employed for Total Gas and Gas Chromatograph data which records 
values in units and parts per million, respectively. Semi-log scales always have a minimum value of 1. Maximum values 
are set in the graph editor and can range from 100 to 1,000,000. The direction of the semi-log scale is either normal 
(higher values at the top), or reverse (higher values at the bottom) and are set in the formatting menu for the particular 
graph in question. No scale changes are allowed in a semi-log graph, and all curves share the same scale minimum and 
maximum values. 
Export Files 
The program also allows user to export individual graph curves as single tab-delimited text (*.txt) files or comma 
separated files (*.csv).  
 
  



Chapter 5 - Survey Data 
The survey data is at the center of the Horizontal XSection Log software, and understanding how it is employed by the 
program will make your use of this software easier and more productive. This chapter goes into detail about the how to 
enter, edit, import and export survey data, and the importance of the survey data to the program.  
Glossary of Terms and abbreviations: 
MD - Measured Depth. INC - Inclination of the survey tool where 0° is vertical and 90° is horizontal. AZ - Azimuth of the survey tool corrected for magnetic declination (0° - 360°). TVD (KBTVD) - True Vertical Depth is the vertical distance from the KB to the survey tool – also known as KBTVD. VS - Vertical Section is the horizontal distance from the well location to the survey tool projected to a vertical plane that is the azimuth from the well location to the "planned" final target location.  NS - North/South, also known as Northings, is the map-view north/south coordinate for the survey tool. Positive numbers denote a coordinate north of the well location while negative numbers denote a southern location. EW - East/West, also known as Eastings, this is the map-view East/West coordinate for the survey too. Positive numbers denotes a coordinate east of the well position, while negative numbers denote a western location. DLS - Doglegs is the degree of curvature measured in degrees per 100'  
MD, INC and AZ, are measured by the down-hole survey tools (by the MWD personnel) and conveyed to the Directional 
Driller. TVD, VS, NS, EW and DLS are derived survey values. The dominate method of calculating the derived survey 
values is the Minimum Curvature method, and is the algorithm used by this software. 
The Tie-In Value 
The tie-in value is the start point for any curve that will be represented in the Horizontal XSection software, and is the 
survey from which all subsequent surveys are derived from. The tie-in value can be any survey, but must include the MD, 
INC, AZ, TVD, VS, NS, EW, DLS, as well as the azimuth from the well location to the final target location. This value is 
often known as the "Direction" or the "Vertical Section along azimuth" value. Without a correct "Direction", the 
software will not be able to accurately calculate the Vertical Section.  
Note: that the tie-in value need not be the same tie-in value that the directional driller (DD) employs. Since, often time 
the Geologist will not be concerned with the up-hole portion of the well, any survey can be used as a starting point. 
To enter the tie-in value click on the menu item Data Entry/Editors->Survey Data Editors-> and the survey lateral to edit. 

 



 
This will open the "Survey Data Sheet" window for the particular lateral chosen. Click on the "Edit / Add Tie-In Survey" 
button to open the "Add/Edit Tie-In" editor. Enter your tie-in survey data, as shown below. 

 
Adding, Editing and Deleting Survey Data  
Once the tie-in survey is entered, new surveys are entered through the "Add New Survey" window(see below). Click the 
"Add Survey" button to open the "Add New Survey" window. Note that the "Add New Survey" window only asks for the 
Measured Depth, Inclination and Azimuth data. The program will compute the derived survey values(TVD, VS, NS, EW 
and DLS) and add the new data to the "Survey Data Sheet" window. 



To edit or delete a survey, just select the particular survey and click 
either the "Delete" or the "Edit" buttons. Slide data is entered on the 
right side of the Survey Data Sheet and is self-explanatory. 
To quickly enter survey data using the above displayed "Add New 
Survey" dialog window, use the "Tab" key to quickly move from field 
to field and press the "Enter" key (same as clicking the "Done" 
button) to enter and close the window; click the "Enter" key again to 
open the "Add New Survey" window for the next survey entry.  
Importing and Exporting Survey Data 
Because it is often easier and faster to enter data in an Excel 
spreadsheet and then import the data into the Survey Data Sheets, 
the Horizontal XSection Log allows survey data to be imported and 
exported. 
Use the "Import Survey Data (*.csv)" and the "Export Survey Data 
(*.csv)" buttons to import and export survey data, respectively. 
However, the data must be formatted in a particular manner, and 

saved as a comma separated values file, also known as comma delimited text files(*.csv), in order for the progam to be 
able to load the file. The simplist manner in which to create a template is to use the "Export Survey Data" button to 
create a CSV file. This file can than be opened by Microsoft Excel, edited, saved, and then imported back into the Survey 
Data Sheet of the particular lateral in question. To create a template, choose one of the empty laterals and open the 
"Survey Data Sheet " as shown above. Enter a tie-in value and click on the "Export Survey Data" button to create a 
CSV(*.csv) file. This file can then be opened in excel as shown below. If you double click a *.csv file, excel should 
automatically open. From within Microsoft Excel choose "Text Files" to display files of type comma delimited (*.csv). 
 

 
The format of a template CSV file is simple:  
CELL A1 has the direction data,  ROW TWO is used as a header for the survey columns,  ROW THREE holds the tie-in value and, ROWS FOUR onward are used for the survey parameter MD, INC and AZ.  The below example shows an Excel file that is ready to 
be imported with some survey data added in rows 4 - 
7. Make sure you choose CSV(Comma Delimited) 
when saving the file, and make sure you close the file 
before trying to import it into the Horizontal XSection 

software. Then simply open the Survey Data Sheet window for the appropriate lateral and import the file. The other 
survey fields (COLUMNS D - H) in rows 4+ are ignored when imported into the Survey Data Sheet window. Horizontal 
XSection will recalculate these values when the surveys are imported. 
Note, when surveys are imported into a Survey Data Sheet, all preexisting surveys, including the tie-in value, will be 
deleted. However, previously entered slide data is not be altered.  
 



As noted above, survey data is exported as a comma 
delimited text file (*.csv). The exported data 
includes all the derived survey values (TVD, VS, NS, 
EW, and DLS).  
Matching the Directional Drillers Values 
Though there are other methods for computation of 
the derived survey values, the most common 
method on horizontal wells is the minimum 
curvature methodvii. As long as the directional 
company is using this method, the values derived 
from the Horizontal XSection software will match 
the values from the directional driller. At times 
rounding differences will result in values that differ 

by a few hundredths. If values differ by more than a few hundredths, examine your MD, INC, and AZ as well as the tie-in 
survey for date entry errors. Also remember that sometimes DD and MWD hands make mistakes too (though they may 
deny it)viii.  
 



Chapter 6 - Lithology Patterns and the Lithology Mode 
Introduction 
The Horizontal XSection program can store 20 lithology patterns. These patterns are stored as bitmap files (*.bmp), 
which uses individual pixels to create an image. When you begin the program, it loads the default patterns (bitmap files) 
into memory. However, it is a simple process to load a custom set of lithology patterns, or to load and/or change 
individual patterns. The process, explained in “Chapter 3 - The File and Formatting Menus", for loading a file with pre-
formatted attributes using the File->New menu item, will also load the files lithology patterns. Lithology mode allows 
you to draw horizontal, as well as dipping beds, add stringers and even put in faults. 
Creating Custom Patterns with Microsoft Paint 
A nice property of bitmap files is that they are simple to create. Microsoft Windows OS all come with a program called 
"Paint", which is a primitive, yet effective way to create lithology patterns, as well as log images (See chapter on log 
images). 
To create a custom pattern, first open the "Paint" program by clicking on Start->All Programs->Accessories->Paint. The 
lithology patterns used in Horizontal XSection Log should be 32 pixels wide by 16 pixels in height. To create a 32 x 16 
pixel canvas, click on Image->Attributes…, to open the attributes window, and enter 32 pixels and 16 pixels in the width 
and height text areas, respectively. An alternative method is to right-click a bitmap file and click "open with" and select 
the "Paint" program from the list of programs.  

 
After closing the attributes window, click on View->Zoom->Custom->800% to enlarge the canvas area. This will make it 
easier to design your pattern. Create and save your custom pattern. It is recommended that you save patterns in the 
"Lithology Bitmaps" folder (this folder is found in the "XSection Utilities" folder located in "My Documents" or 
"Documents" folder).  
Importing Lithology Patterns 
To import or change the name of a lithology pattern, open the "Lithology Image and Name Selection Editor" window by 
clicking on the menu item Mode-> Lithology->Lithology Image Editor… (see below). Next, select the image from the 
right-hand side list of lithologies. Type in a new name for the selected lithology and click the "New Name" button, to 
change or edit the name. The new name will appear in the lithology list, the menu item Mode->Lithology-> "lithology 
list", and the log's Legend. 
To import a new pattern, click the "Change Image" button for the selected lithology, and select the new bitmap file using 
the open file window.  



 
The Lithology Library 
The lithology library import and export buttons are a simple way to import and export a complete library of custom 
patterns. Only import a lithology library at the beginning of a log session, before any lithology beds have been placed on 
the log, or sample percentages entered in the "Samples Track". When a lithology library is imported, all lithology beds in 
the "Cross-section Track" and samples in the "Samples Track" are deleted. A lithology library can be exported at any 
time. Personalized lithology patterns in a log are saved with the log. However, it is suggested that you use the export 
lithology library to backup your lithology patterns. 
Lithology Mode 
As mentioned in the Chapter 2 ("Getting Started"), there are five modes that allow annotation of the cross-section track. 
Lithology mode allows the placement of lithology beds. Lithology mode is automatically selected whenever a user 
selects a lithology pattern either through the Mode->Lithology->… menu or the toolbar. When in lithology mode, the 
mouse pointer will turn into a cross. 

 
To draw a horizontal bed, simply click and hold the left-mouse button, and release when done. 

  



To put an interbedded stringer within a lithology bed, simply choose a different lithology pattern using the menu or the 
toolbar as shown above, and click once without moving the cursor. The program will draw a preset stringer centered 

around the mouse click.  
The stringer dimensions can be reset by the user. Open the "Set Stringer Size" window by clicking on Mode->Lithology-
>Set Stringer Size…, 

 
type in the new "Width" and 
"Height" dimensions in the 
appropriate text boxes, and 
use the “Test” button to view 
the new dimensions; click OK 
when you are satisfied with 
the new dimensions, and the 
new stringer size will be saved. 

When the file that you are working on is saved, the new stringer size is also saved and will be loaded when the file is 
reopened. If a new file is created using the File->New menu item , the stringer size will be reset to the default size of 4o 
pixels wide by 6 pixels in height.  
Delete, Move, Rotate and Resize Lithology Elements 
To delete, move, rotate or resize a lithology element, the user must first be in "Lithology Mode". Then move the cursor 
over any lithology bed or stringer until an orange outline appears, then right click the mouse to open the popup menu. 

 
The "Move" and "Delete" items are self-explanatory. The "MoveToBack" feature will move the selected bed or stringer 
to the back, so that other lithology beds will be displayed over that bed. If this sounds confusing, first draw a few smaller 
beds (or stringers), and then cover the smaller beds with a larger lithology bed. Now use the MoveToBack item on the 
last larger bed that you drew covering the smaller beds, and the smaller thinner beds should reappear over the larger 
bed. Horizontal XSection draws lithology beds in the same order that they were created, and the "MoveToBack" feature 
reorders the drawing queue by moving the selected bed to the front of the queue. The “Resize” menu item can be used 
to lengthen or shorten the width (but not the height) of a lithology bed. 



Rotate 
The "Rotate" menu item will open up ‘Set Angle’ window. There are many different ways to rotate a lithology bed with 
this window. The simplest is to use the up/down arrow keys on the keyboard. 

 
Each depress of the up or down arrow key will rotate the bed by ±0.1°. With the shift key depressed, the increment will 
increase to ±1.0°. Or, the user can enter a number between 90° and -90° and then depress the update button. Bed 
rotation refers to the degrees of rotation shown on the computer screen and is not analogous to the apparent dip of 
said rotation. The apparent dip depends on the TVD scale on the log where the bed is being rotated. However, the “Set 
Angle” window will calculate the apparent dip of the bed from the rotation angle. In the above example, a 1.10° angle 
calculates to a 0.55° dip. Positive dip values are below horizontal (below 90°), negative dip values are above horizontal 
(above 90°). 
 It is fine to enter fractions, for example 0.5 degrees or 2.3 degrees are perfectly valid values. Note, the software will 
automatically adjust the degrees of rotation if the height dimension of the cross-section is changed (see Chapter 3: 
Formatting and the File Menu), so that the rotated beds "fit" the new height. However, changing the TVD scale will not 
affect the rotated beds. Hence, make sure you that you are happy with your TVD scale prior to rotating beds. Also, note 
that rotating horizontal beds will slightly distort the "look" of your lithology patterns. This distortion will only occur on 
the computer screen, not on logs printed on paper, and has to do with the finite resolution and grid-type pixel-format of 
computer monitors. 
Note: the degree of rotation of a lithology bed is not the same as the apparent dip. Due to the vertical exaggeration of 
most logs, the degree of rotation will be greater that the apparent dip.  



Selecting a Rotated Bed 
A rotated bed can be selected, and hence, moved, deleted and rotated (again), just as a non-rotated bed. However, 
selecting a rotated bed can be tricky, especially if the bed is rotated to a high degree. To select a rotated bed, move the 
cursor to the position of the bed if it were not rotated. 

 
Copy and Paste 
A lithology bed or beds (if grouped, see 
below) may be copied and pasted. One 
nice attribute of the copy and paste 
feature, is that rotated beds that are 
copied will be pasted with the same 
degree of rotation.  
Group Lithology Beds 
With the release of the Horizontal 
XSection Version 2.0+ there is now the 
ability to group lithology beds together 
for editing purposes. To group lithology 
beds together, hold down the shift key 
while moving the mouse cross-hairs 
(must be in “Lithology” mode) over the 
lithology beds of interest. The orange 
border that appears when a lithology bed 

is selected will remain selected even after the mouse has passed over the lithology edge as long as the shift key remains 
depressed. The program will draw a slotted rectangle, any bed within the rectangle will be grouped; then right-click the 
mouse key to select the desired action. Only ‘MoveToBack’ will not work on grouped lithology beds. 

 
Following the steps shown in the figure above, it is now 
simple to select multiple lithology beds and either move, 
resize, rotate or copy and paste. 
Creating a Fault 
Displaying faults in the cross-section is simple. The first step 
is to draw your lithology beds showing the displacement of 
the lithology. The below example is an example of how to 
show displacement of a shale overlying a sandstone, 
wherein the borehole goes from drilling a sandstone (the 
pay zone) into drilling a shale at ~1682' MD. 

 
To show the fault, select the lithology 
pattern "Fault or Fracture" from the 
menu or tool bar, and draw a vertical strip 
as shown below; then add a -5.0 degree 
rotation to the fault to give it a more 

realist display of a normal fault, and add an arrow using the draw line feature! 



 
 
  



Chapter 7 - Log Images and Photos 
The Horizontal XSection software has an editing mode called "Add Image" that is devoted to adding images to your log. 
Images may include custom created symbols or events, photo's, or any image type that can be saved as a JPEG, Bitmap 
or TIFF file type. Presently, images may only be added to the cross-section track of the logix. There are a number of log 
images that are preloaded into the "Add Image" dropdown menu when Horizontal XSection is openedx. Moreover, there 
is an extensive library of images for your perusal and use in a folder called "Log Images", found in the "XSection Utilities" 
folder. The Horizontal XSection Log makes it a simple process to add an image to the "Add Image" queue.  
Log Mode 
To change the mode to the "Add Image" mode, either click an image from the "Add Image" dropdown menu, 

 
or select the "Add Image" icon from the toolbar. 

 
The Icon image in the toolbar represents the image that will be added to 
the log and will change only when a different image is selected from the 
main menu "Add Image" dropdown menu. In the example at left, the 
"Bit Trip" image will be selected by clicking on the toolbar "Bit Trip" 

Image Add icon. 
In "Add Image" mode, simply click anywhere on the cross-section track of the log to add the selected image to the log. 
The upper-left corner of the image will appear at the click point. To Delete or Remove an image, move the cursor over 
the image until the orange bounding rectangle appears, and then right-click to open the popup menu. The "Move" and 
"Delete" menu items will be enabled. If you select "Move" by right-clicking the "Move" item from the popup menu, 
move the image to the desired position and left-click to "drop" the image. The "Delete" item works similar to the "Text", 
"Lithology", and "Draw Line" modes. 
Pointer Line Attached to Photo's or Log Images 
Like text blocks, a pointer line can be attached to a Photo or Log Image. Simply right-click the log image or photo, and 
select pointer line from the popup menu. To move the pointer line, move the cursor over the end of the pointer line and 
right-click when the orange selection rectangle appears, and select "Move" from the pop-up menu. Move the mouse to 
the new point (the pointer will follow) and then left-click the mouse. To romove a pointer line from the associated image 
or photo, follow the same process as selecting the pointer line.  When a photo or log image has an associated pointer 
line, the pointer line will have a check mark selection marker in the popup menu. Each photo or log image may only have 
one associated pointer line.  



 
Note: it is advised to use the associated pointer line rather than the 
draw line feature with photos or log images. The reason is so that 
when the zooming feature is employed, the associated pointer line 
will be scaled correctly with the Photo or log image. This may not be 
the case with a line drawn using the draw line feature. 
 
 
Adding / Removing Images to the Add Image Dropdown Menu 

Horizontal XSection makes it very easy to add images to the Dropdown Image list. Note, that all images under a quarter 
of an inch in height and half an inch in widthxi that are displayed in the "Add Image" dropdown menu, will also appear on 
the log legend, when the log is printed. The legend can hold about 25 images. It is also very easy to remove images from 
the dropdown menu. Note, however, when an image is removed from the drop down menu, those same images on the 
log are not removed.  
To remove or add images to the "Add Image" dropdown menu, open the "Add / Remove Graphic Images" window by 
clicking on the "Add / Remove Image(s)…" menu item as shown below. To delete an image, select the image from the 
"Select Image:" list and click on the "Delete Selected Image" button.  

 
To import a bitmap, jpeg or tiff image to the “Add Image” drop-down menu,  click the “Import Image (*.bmp, *.jpg, 
*.tif)” button, which will open the "Open" file window. Presently, you are limited to importing the following file types: 
Bitmap's (bmp), JPEG's (jpg) and TIFF's (tif). However, this should cover the types of images most users will want to 
import. Use the dropdown menu in the lower-right corner of the "Open" file window to choose the file type of the image 
that you want to import.  



 
After you choose the image with "Open" file window, you will be prompted to give a name to the image that you are 
importing. The image name does not need to be the same name as the file that is being imported, and will be the name 
that appears in the dropdown menu, and on the log legend.  
Creating Bitmaps 
The simplest way to create log images like fossils or accessory minerals, is to use the "Paint" program that is part of the 
Microsoft Operating System (also see chapter 6 - creating patterns) :  
1) Open paint by clicking Start->Programs->Accessories->Paint. 
2) On the Paint programs menu bar click on Image->Attributes (or ctrl-e) and set the width to 15 pixels and the height to 
16 pixels. Larger or smaller images may be created, however, the image shown on the XSection menu will be distorted 
to fit the dropdown menu image space . The image drawn on the log, will be exactly the same as the image created in 
the Paint program.  
3) On the paint programs menu bar click on View->Zoom->Custom->800%. 
4) Create your design and save it to a location you will remember as a bitmap (*.bmp). You may also save the images as 
jpeg's and or tiff files. 
Bitmap Library (Log Images - XSection Utility Folder) 
When the Horizontal XSection program is installed on your computer, a folder called "XSection Utilities" is created in the 
"Documents" section of your computer. This folder contains a folder called "Log Images", which contain three folders 
("Fossils", "Minerals" and "Misc Images") with an assortment of bitmap images that can be loaded into the program for 
your use.  
Importing Photos and the "Set Max Dimension" 
Most photos will be saved as JPEGS. When importing a photo into the "Add Image" queue, the software will resize the 
image so that the largest dimension is no greater than the "Set Maximum Value" selection. Hence, there is no need to 
resize photos before importing them into the program. Use the drop down menu to select any maximum dimension 
from 1" to 5" (in 0.5" increments). Once you are done adding photos to the log, you may delete the photo from the "Add 
Image" queue. Deleting the photos from the "Add Image" menu will decrease the size of the log file (*.hxl), without 
affecting the photos in the log. Photos in the "Add Image" menu will not appear on the log legend when the log is 
printed.  
Note: Be careful when changing the cross-section height dimension (see chapter on formatting) or the log scale 
because the size of photos (and all log images) are not affecting by changing the size of the cross-section dimensions 
in the way that other elements (i.e. Lithology beds) are affected. Hence, a one-inch photo inserted into a log will 
always be a one-inch photo regardless of cross-section track dimensions. 



Append Photo (or any Image), and Text to any "Log Image" or Photo Thumbnail 
Photos and text can be added as an appendage to any log image or photo by simply selecting the photo or image and 
right-clicking the mouse. For example a large photo can be appended to a photo thumbnail on a log. The appended 
window has two tabs, one for photos or other images, the other for text. The below examplexii shows each tab reduced 
~30% to fit in this manual. 
9" X 6.75" Photo display 

   
 
 
Add Descriptions, reports, casing information, bit info etc… 



 
When a log image has an appended note or image, that log image will have a constant violet colored border. The below 
example shows a "Bit Trip" image with an appended bit report (not shown), a thumbnail with an appended image (see 
above) and a "Midnight" symbol with an appended midnight report.  

The image tab displays a 9.00 X 6.75" photo. The program will automatically 
resize large photos to fit in the available space. The method of importing an 
image is to "drag and drop" the selected image into the image tab in the 
'Append Image/Text" window.  
How one selects to open the appended images or notes depends on whether 
one is using a licensed version or the log viewer version of the Horizontal 
XSection Log: 
 In the log viewer, click on any log image with a violet border. 
 With a licensed version, first select "Add Image" from the mode menu 
or toolbar, then right-click over the 'Log Image' or photo  and select "Append 
Photo/Notes…" from the popup menu (see first image on pg. 2). 

Possible uses of this new feature:  
 Link large photos to embedded photos. 
 Link a "Show Report" in the text tab to a "Show" (oil or gas) image 



 Embed morning or afternoon reports to a AM or PM report image. There is now a default "AM and PM Report" 
Log Image as part of the default log. Or go to "C:…\Documents\XSection Utilities\Log Images\Misc Images" to 
add the AM or PM report images to the 'Log Image' menu. 

 Similarly embed Frac reports for each staged fracture to  a frac report log image. 
 Add Correlation images exported from the Geosteering tool. 

Log Size 
Appending a photo that fills the 9" X 6.75" image tab will increase the size of the log by ~1MB. As a test, a log with 7 
thumbnails with appended photos was ~9.5MB. High-speed internet connections on a well-site location are often slow 
or sporadic, and emailing a log with many appended photos can be difficult. In these situations, it may be advisable to 
wait until a high-speed internet connection is available before appending photos and emailing large MB log files (*.hxl). 
 
  



Chapter 8 - Printing 
Page Setup 
The first step in printing your log is to click on the File->Page Setup menu item to open the "Pages to Print" and the 
"Page Setup" windows, which appear in successive order. 
  First      Second 

 
The "Pages to Print" window allows the user the options of choosing the printing interval, whether to include the title 
page and legend, and whether to "Scale to Page". After clicking OK, the Page Setup window will appear. By default, the 
page orientation will be set to "Landscape". Also, by default, the "Left" and "Right" margins are set to zero. It is 
suggested you keep this default value at zero. The "Top" and "Bottom" values are set by the program to center the log in 
the center of the page. If the total log height of all your tracks is greater than 8.0" and you have not checked the "Scale 
to Page" box, you will get this warning message (see below) between the Pages to Print window and the Page Setup 
window: 

 
It is fine to disregard the warning, for example, if you have paper 
that is wider than 8.5 inches, or are printing in portrait mode, or 
are not concerned about fitting the log on the paper. Otherwise, 
use the Horizontal XSection formatting windows to reduce the log 
height (see "Chapter 3 - The File and Formatting Menus"), or 

select the "Scale to Page" option. 
Scale to Page 
The best way to use the software is to set the sum of all the track heights to no more than 8”. If the user wants to see a 
larger log on their computer screen, the zoom feature works well. By setting the track heights to a cumulative height of 
not more than 8”, printing on 8.5” wide paper is a snap. However, if the log height is much greater (or less) than 8.5 
inches the “Scale to Page” feature in Page Setup will print an accurate log. 
Check the "Scale to Page" box if prefer to have the program scale the track heights to fit on 8.5" wide page printing in 
landscape mode. When this feature is enabled, the software will either increase or decrease the heights of all the 
enabled tracks so that the sum of the track heights is 8”. Lithology beds, lines, text location and TVD logs will all be 



scaled and moved accordingly. Even the rotation of lithology beds should be accurately changed. However, images and 
text fonts will not be altered, so there may be differences between what is on the computer screen and what is printed. 
This is especially true if you are using the "Scale to Print" feature to reduce the log size by greater than 10%, so use this 
feature carefully. 
Printing 
Once the "Pages to Print" and the "Page Setup" has been set, simply print the log using the "Print" menu item or the 
print icon on the toolbar. When you click the "Print" menu item or tool bar, the print dialog window will appear. Use this 
window to select the appropriate printer as well as to select banner printing, if appropriate. 
Print Preview - creating a PDF file 
Presently, there are is no print preview ability in the Horizontal XSection software. However, there is a simple way to 

preview your printed logs by creating a PDF file 
of your logxiii. Go to 
http://sourceforge.net/projects/pdfcreator/ 
and download and install the PDF creator on to 
your computer. This software is free and easy to 
use. When you are ready to print your log, 
choose the PDF creator from the choice of 
printers. 
Rather than printing the log to the computer, 
the PDF creator will create a PDF file of your log 
that is exactly the same as if you had printed 
the log to paper. In this way you can proofread 
your log, as well as ascertain the page length of 
you log, or send the PDF file to clients so that 
they can print out the log.  
WARNING: there are some problems with 
creating a PDF file using the above mentioned 
procedure. First  I have tested a lot of PDF 

printers and they all create TVD Logs on the cross-section that are 100% opaque, even if the opacity setting of the TVD 
log was less than 100% (i.e. 50%). This is not an issue with my program but with the PDF printers! Second, on some 
computers it was necessary to set the PDF printer as the default printer in the control panel, otherwise the program 
would not successfully create a PDF file. 
Continuous (Banner) Printers 
Continuous banner printers have become much harder to find. I have had good luck with a printer sold by Well Green 
Tech (http://www.wellgreentech.com/Well_Log_Printer.html).  
  



Chapter 9 - Sample Track, Histogram Track and the Tools and Views Menu 
The sample and histogram tracks use a similar user interface for entering data. The tools menu offers a variety of 
options for improving your log, and making your log editing experience faster and easier. 
Adding Samples Data to the Sample Track 
The first step is to format the sample track using the Formatting->Sample Percentage Track menu item, as discussed in 
"Chapter 3 - The File and Formatting Menus". To enter sample percentage data, simply click on the "Sample Percentage" 
track as shown below.  

 
For example, if you are entering data from the 
sample 3250' - 3260' interval, click at between 3250' 
and 3255'. This will open the sample percentage 
editor with the correct sampling depth interval as 
shown below. 
You can enter up to 10 different lithology 
components into each individual sample. Samples 
can be broken down into 5% component 
increments. However, it is suggested that for a 
"Sample Percentage" track height set at less than 1", 
avoid a 5% only component because it will barely be 
visible due to the finite resolution of most computer 
screens. 
As components are added, the "Percentage Left" 
value decreases. Also, a preview area shows what 
the sample interval will look like on the log. Only 
when the "Percentage Left" is 0, will the user be able 
to click either "<<Prev", "Next>>" or "Done". The 
"<<Prev" and "Next>>" buttons will enter your 
selection and increment the sample interval up or 
down hole, respectively. The "Done" button will 
enter the selection and close the window. 
New Feature: Depress the shift key while clicking the 
“Next>>” button to advance to the next interval 

while retaining the same lithology % for each sample component. 
Use the "Save Lithology Order" and "Load Lithology Order" buttons to save and load, respectively, the lithology 
components. Clicking on a sample interval that already has sample data, will open the "Add or Edit Sample Percentages" 
editor, preloaded with the appropriate data. To delete a sample interval, move the mouse over the sample interval to be 
deleted and right-click to open the pop-up menu, and then select "Delete" as shown below. 



  Delete sample      Set Sample Interval 

 If the "No Sample" check box is clicked, a red X will appear at the corresponding sample interval (see above).  
When a Horizontal XSection session is started, the default sample interval is 10'. Use the menu item Tools->Set Sample 
Interval… to open the "Set Sample Interval" editor, and change the sample interval as desired. Note the default sample 
interval is used for both the "Sample Percentage" Track and the "Histogram" tracks.  
Improved Histogram Track 
The histogram track has been rethought and improved to be both simple to use, and more versatile, than the original 
1.0+ version.  The histogram track can be configured into two modes: factor or values mode. A value “-999” in the 
“Factor:” box (i.e. below figure), enables values mode for the histogram. All other decimal values in the “Factor” box 
enables factor mode, and the “Displayed Values:” values are disabled (and ignored by the program). 
Values mode 
When the program is started, all three available histogram tracks are, by default, in values mode.  The histogram values 
must be inputted by the geologist / user in the “Displayed Values” area. The values need to be separated by commas 
(comma delimited). For example, if the user enters the values “6%,12%,18%,24%” (there is no need to put in spaces 
between values), the histogram track will have five values: none, 6%, 12%, 18%,and 24% (i.e. vales for a porosity 
histogram). Another example would be to enter: “trace,fair,poor,good,v.good,excellent”. 
This would translate to a histogram with the values: none, trace, fair, poor, good, v.good, and excellent (i.e. oil show 
histogram).  “None” does not need to be entered as a “Displayed Value”, it is added to the histogram by default as a 0 
value.  When in values mode, the “Scale:” drop-down menu box will be ignored. In values mode the scale of the 
histogram is always set by the number of values separated by commas plus the “none” value. The “Visible Divisions:” 
drop-down menu box is still used in values mode for selecting the number of horizontal divisions for the particular 
histogram track. 
The below figure shows a portion of a histogram formatting editor set for values mode, with the Factor box set to -999, 
and the values of the histogram being set to 6%, 12%, 18%, and 24%.  

 
Factor mode 
The histogram is in “Factor” mode when the “Factor” value is set to any decimal value other than ‘-999’. When in 
“Factor” mode, the “Displayed Values:”, used in “Values” mode are ignored by the program. 



The basic procedure for using the histogram in factor mode is to pick a scale using the “Scale:” drop-down menu. Any 
scale from 2 through 20 can be selected (in the previous version, the histogram scale was immutable, set at 10). After a 
scale is selected, the user inputs a “Factor” value, which can be any decimal number.  The program computes the 
histogram values to be selected by the user by multiplying each scale by the factor. 
In the below example, the scale is set at 20, with a factor of 5. This means that the histogram values for the % Cavings 
Histogram will be: 0, 5, 10, 15….90, 95, 100. When the user clicks on the % Cavings histogram track, they will be 
presented with a drop-down menu with the above just mentioned values as shown below. 

 

 
 
 
 

Adding Histogram Data to the Histogram Track 
Similar to the sample track, to add data to the histogram track the user may simply click on the histogram track near 
where they want the data to go. This will open the histogram track editor allowing the user to edit the depth interval 
and the value of the histogram 
Click and Drag 
A new feature in Horizontal XSection version 3.0+ is the ability to draw the histogram value using the mouse. Simply, 
hold down the shift key and draw in the interval and value of the histogram. When the left mouse key is released, the 
histogram editor will open with the depth intervals and histogram values filled in based on the click and drag position. 
 
Tools Menu 
The "Tools" menu as the name suggests contain an eclectic set of tools and is accessed from the main menu (see below). 
Each of these tools and their uses are described below. 



 
Set Sample Interval 
Opens a window where the default sample interval for both the "Histogram" and "Samples" track can be set. 

 
Set Default Text Styles 
Opens a dialog window where the default text including font size, font color and background color, can be set for either 
this particular session, or for the program in general.  

 
By checking the "Set Text 
Styles As Permanent Default", 
the selected Text Styles will be 
saved for future sessions of 
the Horizontal XSection 
program, otherwise any 
changes will only be saved for 
this particular session.  
Delete 
The delete feature allows the 

user to delete particular sections of the log. for example, all the Samples, or all Text Line or Lithology elements. 
Histogram tracks can quickly be cleared using the delete tool. Be careful though, there is no "Undo" feature for the 
delete tool! 
Clean-Up Log Utility 
The feature will delete all elements of the log that are partially or wholly out of the viewing area. When a log is 
shortened, or a TVD scale changed, elements of the log may no longer be visible to the viewer, but still exist in computer 
memory. This utility will delete these elements, though there is no harm to their existence other than a larger file. Be 
careful with this utility, for there is no undo feature, and there maybe reasons to keep these elements. 



Dip Calculator 
There are two procedures for calculating the dip or apparent dip with the Horizontal XSection software. The first 
procedure is described in detail in "Chapter 2 - Getting Started", and involves drawing a line between two points and 
right-clicking the mouse.  
The second procedure involves opening the "Dip Calculator" from the "Tools" menu. The dip calculator, as shown below 
is a simple calculator that takes two depths (VS1, and VS2) and two TVDs (TVD 1 and TVD 2), and calculates the angle 
defined by these values. The depths are labeled VS for vertical section, because using VS values obtained from the 
Horizontal XSection program, will result in the most accurate apparent dip values, assuming that the actual AZ is near 
the planned VS plane. Only use "Measured Depth" values if you are drilling with a near 90° Inclination, and only if VS 
values are not obtainable. Check the subsea checkbox to use subsea numbers instead of TVD numbers. The program will 
automatically detect the dip direction (i.e. "Up" or "Down"). 
  Using TVD Values      Using Subsea Values 

 
The "Dip Calculator" can remain open while working on other aspects of your log, and is set to always be the top-most 
window. 
Subsea 
When the "Subsea" feature in the tool menu is enabled, the TVD scale on the cross-section will be replaced with Subsea 
values. Moreover, the TVD value in the status label at the bottom of the window that displays the survey data, will be 
replaced with subsea values (See red circles in below example). This feature can be toggled on and off, as desired, so 
that both TVD and Subsea values are easily accessible. 



 
Geo-Steering Correlation Tool 
This tool will open "Geo-Steering Correlation" instrument. See "Chapter 11 "(Geo-Steering Correlation Tool) for more 
information. 
Expand Toolbar Lithology Images Menu Item 
The expand toolbar lithology images menu item found in the “Tools” drop down menu (see below), expands the 
lithology buttons on the toolbar to exhibit the lithology patterns exactly as they will appear on the log. A wide monitor is 
helpful for this feature. 

Calculate Kick-Off Point Calculater 
The “Calculate Kick-Off Point…” menu item, as the name 
suggests, opens a build-in calculator that allows the user to 
determine the Measured Depth kick-off point (KOP). The 
calculator, based on the desired build dogleg, KOP inclination, 
landing point inclination and landing point TVD, will determine 

the KOP as a measured depth value, if the KOP is in a vertical 
borehole, or the KOP as a TVD, in an inclined or deviated 
borehole.  Besides the MD Kick-off point, the calculator will 

determine the ‘Build Length’ as a measured depth value, the 
measured depth landing point and the vertical section at the 
landing point away from the KOP. If the KOP is in a deviated well, 
the calculator will not calculate the MD landing point, and the KOP 

will be a TVD value. It will still calculate the Build length, so if the MD at the TVD kick-off point is known, the MD landing 
point will be easy to calculate (MD Landing Point  = MD KOP + Build Length). 

Expanded Lithology Buttons



 
Views Menu 
There are two sub menus 
under the “Views Menu”:  
“Plan Or Map View” and the 
the “TVD vs. Vertical Section” 
menus. 
Plan or Map View 
Clicking the “Plan or Map” 
menu item will open a new 
window with a map view of all 
the laterals, including surface-
hole location and bottom-hole 
location. The user can then 

add landing points, hard lines, and text (screen shot example below).  
 
Up to four separate hard lines can be plotted 
corresponding to the four directions. Hard lines 
are drawn by the computer in red and are set 
according to the wells surface hole location. For 
example the “North” hard line is drawn below 
from a point 2500’ north and 2000’ west of the 
SHL to a point 2500’ north and 0’ west of the 
SHL. Enter -9999 for no hard line to be drawn. 
Each lateral can have one landing point, which is 
usually the measured depth location where the 
build ends. To enter a landing point using the 
“Landing Point Editor”, select the lateral of 
interest from the drop-down list, and enter the 
measured depth where the landing occurred. 

The program will then plot a blue and yellow rectangle at the appropriate map view location. Enter “-999” and the 
program will not plot a landing point symbol. 



 
Map scales for both the north/south and east/west axis can be adjusted by using the “map Scale” drop down menu 
items: 

 
Similarly, the SHL map position is automatically set by the computer based on the well plan or lateral #1 direction, but 
can also be manually set using the “Set SHL Map Position” drop-down menu. 
 
  



Chapter 10 - TVD Logs  
TVD Logs 
The Horizontal XSection Log program allows the user to add logs (usually gamma, but can be any log type) to the cross-
section, to be used as a correlation tool. These logs can be offset logs, the pilot hole log, or the LWD log (corrected for 
TVD), from the build section of the lateral. There is no limit to the number of TVD logs that can be added to your log. 
Each TVD log can hold one or two curves, and can be rotated on the log to match apparent dip. Moreover, the log can be 
made semi-transparent (called opacity), so that the other features of the log can be seen underneath the TVD Log.  
Examples of TVD logs set to 50% opacity (opacity is the opposite of transparency) 

 
There are two steps involved in the process of adding a log curve to your cross-section. The first step is to upload the log, 
or logs to memory. When a log has been uploaded, it will be displayed as a menu item under "TVD Log" in the "Mode 
Menu" (Mode->TVD Log ->'list of logs'). 

 
The above example shows four logs that are in memory. Once a log is in memory, it will be saved with the file when the 
file is saved. The second step is to select a log from the menu, and then add the selected log to the cross-section track. 
Loading a Log 
The process of loading a log is simple, and similar to loading curves into the graph tracks. The first step is to open the 
"Cross-Section TVD Log Editor…" by selecting this option from the "Data Entry/Editors" menu. 



 
This will open the log editing window (see below). This window will display the list of loaded logs on the right and the 
corresponding information for each log on the left, on the far right will be a graphical display of the loaded log.  
Note, the log when added to the cross-section may look different than in the “Log Editing Window” because it will 
automatically be scaled to the Cross-Section Track’s TVD Scale.  
The second step is to click the "Load New Log" button. After clicking this button the user will be prompted to select the 
log to be loaded. The default log file type is a text files (*.txt), but Comma delimited files (*.csv) as well as LAS (2.0 
Standard only, no wrap) files (*.las) can also be loaded. Once a log has been loaded, the final step is to edit the log in the 
"Import Log Data and Log Information" window (see below, next page, left figure). It is here that the log depths are 
selected, the log is given a name, the log type is entered (optional), and the KB elevation for the log is entered (optional).  
Note: the default KB value of -999, which tells the program that no KB elevation has been entered.  
The advantage of entering a KB elevation, is that it is displayed with the log. Moreover, it allows the user the ability to 
display the log in subsea depths rather than TVD. 
                                    Log Editing Window 

    
Deleting a Log 
To delete a log simply select the log from the list in the "Cross-Section TVD Log Editor" and click the "Delete" button. 



Editing a Log 
A new feature with Horizontal XSection version 3.0+, gives the user the ability to edit logs after they have been loaded 
into the “Cross-Section TVD Log” editor. Simply click on the “Edit Log” button (see above figure) to open the “Edit TVD 
Log Information” window (see below – next page, right figure). Though actual log numeric values data cannot be added 
or edited, the “Edit TVD Log Information” window allows the user to edit the log name, scales, start and end depth(s), KB 
elevation, and log type values. When done adding, deleting or editing TVD logs, click the “Done” button to exit the “TVD 
Log Editor” window. The new and or edited logs are listed in the Mode->TVD Log menu at the top of the program 
window. 
 Import Log Data and Log Information Window     Edit TVD Log Information Window 

 
Adding a Log to the Cross-Section 
To add a log to the cross-section, the first step is to be in the "TVD Log" mode. As mentioned in previous chapters, there 
are presently five modes (possibly more in later versions), of which "TVD Log" is one. In this mode, logs may be added to 
the cross-section and / or moved, and their display edited. There are two ways to select "TVD Log" mode. The first is to 
select a log from the menu list (Mode->TVD Log->'Select a log') as described above. This will automatically change the 
program into "TVD Log" mode. The other method is to click the  icon on the toolbar. This too will switch the program 
into TVD Log mode. Once in log mode, click anywhere on the cross-section to place the selected log type onto the log To 
‘Move’, ‘Delete’, change ‘Opacity’ or  toggle ‘Subsea’ option, move the mouse over the TVD log (an orange border will 
appear) and right-click the mouse to open the pop-up menu. 
Setting Log Opacity 
Log Opacity refers to the transparent state of the TVD Logs that have been added to the cross-section. A TVD log with an 
opacity value of 100% is completely opaque. Log opacity values are set by the user and range from 25% to 100%. The 
example below shows the same TVD log with varying opacity values. 

 



To set the opacity value simply move the mouse over the log in question until the orange bounding rectangle appears, 
right-click and choose the "Log Opacity…" menu item to open the "Set Log Opacity" window. 

 
Simply set the slide to the desired value and click the "Done" button. When TVD logs are first imported the default 
opacity value is 100%, or completely opaque. 
Log Subsea 
Just as with the cross-section track, individual TVD logs can be set to display subsea depths (instead of TVD) along the 
depth axis. Simply right-click and select subsea to have the log display subsea depths. 
       TVD    Subsea  

 
Missing TVD Logs 

 
If you open a file by double clicking on a log file (i.e see above), rather than using the "File->Open" menu item, you will 
find that the "TVD Log" list will be empty, even if the double-clicked file (*.hxl) contains saved TVD logs. 
 
 
 
 



Empty "TVD Log" List     Open and Close the "Cross-Section TVD Log Editor" 

 
To rectify the situation, open and close the "Cross-Section TVD Log Editor" and the list will appear.  
  



Chapter 11 - Geo-Horizons in the Cross-Section 
 
Geo-Horizons - Tops, Faults and other 2-dimesional Surfaces 
 

Geo-horizons allow the program to 
delineate planes of importance that can 
be projected on to the TVD vs Vertical 
Section view. In the example at left, the 
formation tops (and bottoms) and the 
fault are all projected from the mudlog 
to the TVD vs. Vertical Section using the 
geo-horizon feature. Any two-
dimensional feature can be added, like 
porosity zones, oil/water contact, 
member tops, faults and or fractures. 
Geo-horizon Editor 
The first step in creating Geohorizons is 
to open the geo-horizon editor from 
the “Geologic Tops / Horizons” sub-
menu. This will open up the geo-
horizon editor.  

 
 
Use the “Add” button to create a 
new Geo-horizon, then use the 
“Change Top / Horizon Name” to 
give the new Geo-horizon a name. 
The “Line Attributes” allows the 
user to edit the Geo-horizon for 
‘Line Style’,’ Line Width’ and ‘Line 

Color, much as in previous editors for the graphs and survey data. The visibility check box allows the user to toggle 
(visible or not visible) whether the Geo-horizon is displayed on the mudlog cross-section track. The Geo-horizon is 
always displayed on the “TVD vs. Vertical Section” view. 
Geo-horizon Data 
Geo-horizon data consists of a list of Measured Depth (MD) and true vertical depth (TVD) values. Though the easiest way 
to enter a Geo-horizon is on the mudlog directly (see below), Geo-horizon data can be entered using the “Edit” feature.   
Projecting Geo-horizon Data onto the “TVD vs. Vertical Section” View 
To display a Geo-horizon onto the “TVD vs. Vertical Section” view, the program must project the geo-horizon data from 
the mudlog cross-section track to the “TVD vs Vertical Section” View. This is done my converting the measured depth 



values in the Geo-horizon data 
to a corresponding VS values 
by culling the survey data and 
converting each MD value to a 
corresponding Vertical Section 
(VS) value. This can only be 
done if there is a 
corresponding VS value for 
every MD value of a Geo-
horizon. If there is no 
corresponding VS value, the 
Geo-horizon will not draw that 
particular point on the TVD vs. 
Vertical Section view. For this 
reason, Geo-horizon points 
that fall outside the survey 

data (whether it be a well plan, lateral or sidetrack) will not be drawn. Often times, if you have multiple survey data 
curves on your log, for example a well plan and a lateral, there may be more than one VS value for a corresponding MD 
value. In this case the program will use whichever VS value comes last in the list.  If your first survey curves are a well 
plan a lateral #1 and a lateral #2, the projection for a particular MD value will first look at the well plan survey data, then 
the lateral #1 survey data and finally the lateral 2 survey data. If they all have data for a particular MD, the lateral #2 
survey data will be used by the software. 
Adding Geo-horizon Data to the Mudlog 
The first step to adding Geo-horizon data is to switch to “Geo-Horizon” mode using the Mode menu. 

This will open a list of Geohorizons that the user has created using the 
Geo-horizon editor. Select the appropriate Geo-horizon and then click 
done. The cursor will appear as a cross-hair. Move the cursor to 
where you want the next Geo-horizon point to be a left-click the 
mouse. This will draw the Geo-horizon from the last point to the new 
point. Use the Escape (Esc) key to delete the last point. 
 
 

 
In the above example, the sandstone ‘target zone’ is delineated by a dashed blue Geo-horizon layer (top) and a dashed 
red Geo-horizon layer (bottom). The figure below shows how these layers will be projected onto the “TVD vs. Vertical 
Section” view. 



The Geo-horizon layer must be drawn in a forward, down-hole or increasing 
measured depth direction. Each new point must have a higher measured depth 
value than the previous Geo-horizon point. A Geo-horizon point that has a lower 
measured depth value will not be recorded by the program. This means that faults 
must be drilled at a slight angle as shown in the example below with the fist point 
at a lower MD than the second point. 

 
Edit Feature 

Data can be edited by opening the “Edit” window in the 
Geo-horizon editor. This is done by selecting the Geo-
horizon in question and clicking the ‘Edit” Button.  The 
Geo-horizon data editor is similar to the editor for the 
graph curves, and consists of two columns, one for the 
MD value and one for the TVD value. 
 
 
 
 
 
 
 
 
 
 

  



Chapter 12 - Geosteering  Tool 
Introduction 
The Horizontal XSection Pro version comes with an integrated Geosteering tool that works in conjunction with the main 
part of the Horizontal XSection Program. The geosteering tool takes the TVD logs created in the main portion of the 
program (See Chapter 10 – TVD logs in the Cross-section) that the user can use as models for correlating the LWD 
gamma with an offset well or pilot-hole logs. Tops and gamma markers can be added to the geosteering model and then 
within the tool, Geohorizons can be created that are transferred to the main logging program. The Geosteering Tool can 
be accessed through either the Menu Item Tools->Geo-Steering Tool…, or by clicking the Geosteering toolbar icon 
shown circled in red below. 
 

 
 
Once the Geosteering tool is opened, there are a set of tabs on the right-hand side of the screen that allow the user to 
access the different controls for correlation. The tabs are labeled “TVD Log”, “Lateral”, “LWD” “Dip(s)” and “Color”. 



 



The visual part of the geosteering tool is made up of 4 
panels. The left-side panel contains the “Log 
Correlation Panel”. This is where a model gamma 
curve is loaded and used to match the TVD and LWD 
gamma to determine formation dips. The Partial-Well 
Panel shows a user-determined footage interval, the 
default being 1000’. The middle panel is “Graph 
Panel” shows the MD gamma for the Partial-Well 
Panel Measured Depths. And finally, the top “Whole-
well Overview Panel” shows the whole well with the 
Partial-Well Panel footage delineated by a blue box. 
 
The rest of this chapter goes through a step by step 
process of how to use the geosteering tool both for 
landing and staying within the target zone. 
TVD Logs and the TVD Log Tab 

When the Geosteering Tool window is 
opened, the TVD Logs that 
had been loaded into the 
programs memory using 
the Cross-Section TVD 
Editor (described in 
chapter 10) will be 
available to the user in the 

"TVD Log" tab. Select the TVD log for the 
model from the "Select TVD Log" drop down list, at 
the top of the "TVD Log" tab. Once selected, click the 
Load Selected TVD Log button, and the selected log 
will appear on the left side of the screen. 
Color-Coding 
The program will automatically color-code the log 

depending on the settings of the Low and High Gamma Values. To change the gamma values use the arrow keys to 
either move up or move down the values. Any section of the log with a value below the Low Gamma value will be color-
coded blue, while any values higher than the High-gamma value will be color-coded orange. Values in-between the two 
values will be color-coded yellow.  
 
 
 
Target Top and Bottom 
Target top and bottom are shown in the TVD log as red lines with their default location at the top and the bottom 
respectively, of the TVD log. To move the target top and bottom lines simply use the up and down keys in the TVD tab.  
Note: Depress the Shift key while clicking the arrow-keys to increment by values of 10. 



When the top and bottom targets are moved in the TVD log, the associated top and bottom target lines are also moved 
in the partial and whole log panels. The target top and bottom lines are always annotated with the “Target Top” and 
Target Bottom” respectively directly above the lines int eh TVD log panel as well as the partial and whole well panels, 
and are always drawn with a thick red line. 
 
Adding Other Tops 
Adding other tops is as easy as depressing and holding down the left-mouse button while moving the mouse up or down 
to exactly place the top. When the mouse button is released a window will open that allows the user to name and chose 
the color of the top. 
Reference Depth Offset 
The reference Depth Offset moves the footage scale bar on the left-hand side of the TVD log reference scale. The default 
is to have the 0 depth at the top of the TVD log. 
Zooming 
The log-correlation panel that holds the offset log model can be zoomed in to show a more detailed view of your 
correlation. Up to three different zoomed panel views can be saved. To create a zoomed in log-correlation panel move 
the mouse over the panel and depress the shift key. This will create a black rectangle that will delimit the new view. The 
new view can be saved to the F2, F3, F4 and F5 buttons. Use the Tools->Clear Zoom Keys to reset all the Zoom keys. 
 
 

                                                                                                                             
Lateral Tab 
The lateral tab is where the user choses which lateral to use in the modeling. In the XSection Parameters portion, use 
the up and down arrow keys to position the cross-section by moving the TVD Top and TVD bottom values up and down. 
The Partial Well-XSection also has and offset value to move the cross-section up and down. Each parameter has a reset 



button to return to the beginning values. The XSection View drop down menu controls how much MD footage is shown 
on the partial well panel.   
 

 
 
 
LWD Tab 
Use this tab to control aspects of the LWD curve used in correlation. The first step is to select the curve (usually gamma) 
that will be used in the correlation. Use the drop down menu to select the appropriate curve that has been imported 
into the regular logging program. 
 
Once selected, the next step is to select a Start and End depth for the LWD data. Even though the regular log may have 
data starting near the beginning of the well, and far up-hole of where the correlation will take place, most of this data is 
not needed. Choose a depth near a known correlation point. For the end depth, choose a point past the end planned TD 



measured depth. Sometimes you may not want to show all the LWD data, in which case choose a End depth less than 
the drilled depth, and the program will only show LWD to the chosen End depth.  
 

The Sensitivity value is a way to clear out some of the noise. If set to 1, 
every LWD data point for every foot drilled will be shown on the log 
correlation panel LWD curve. If set to 2, then every 2nd foot, if set to 3 
then every 3rd foot etcetera. The below example show the Log-
correlation panel with sensitivity set to 1’ and to 5’. 
 
The LWD Reference TVD value is used at the beginning of the correlation 
process to match up the start value of the LWD curve with your model. 
By default, the LWD curve reference TVD value is the start MD depth’s 
actual TVD value based on the Lateral chosen in the “Lateral Tab”.  The 
LWD curve will begin at the top of the Log Correlation panel. Use the 
“LWD Reference TVD arrow keys to set your initial correlation depth by 
matching your LWD curve to the model curve. Usually this means clicking 
the up arrow key until you get a match. See the Below example.  

 

 
 
Once the LWD Reference TVD is adjusted for an initial correlation match, it will not be adjusted for the remainder of the 
geosteering. 
 
 
The LWD API Shift arrow keys will move the LWD curve left and right as needed to make correlation easier to see. 
 



Dips Tab 
The Dips tab is where you can adjust your dips to make your correlation work. In the below screen shot we have an 
initial match between our LWD curve (Blue) and our offset gamma, but the dip is not quite correct. 
 

 
 
Dips can be added at any interval as the well is drilled ahead. 
 
Colors Tab 
The colors tab can be used to change the color of the LWD gamma curve on both the Log-Correlation panel and the 
Graph panel to better help with correlation. 
 



 
 
 
Lateral Length Menu Item 
Set the lateral length menu item to the length of the lateral starting at you your LWD Tab Start MD depth to the planned 
TD. For example, if your LWD Tab Start depth is set at 10300’MD and planned TD is 17,200’ you would want to set your 
Lateral length to 7000’. A value that is too short will not computer the whole-well overview panel correctly, and a value 
that is too long will slow down the program (though it will compute correctly). 
 
 
 
 
 
 



 
 
Tools Menu Item 
The tools menu item has two items. The Clear Zoom Keys that has been previously discussed and the create Geohorizons 
tool. 
Create Geohorizons Tool 
This tools takes the tops (i.e. Target Top, Target Bottom and any other line) created in the GeoSteering tool and create a 
geohorizon line at the appropriate location on the log. This line can also be viewed on the TVD vs Vertical Section tool. 
This way a geohorizon with the correct dips from the Geosteering tool can be transferred to the log. The best way to 
understand this tool is to experiment. Any line that is transferred to the log from the GeoSteering tool can be deleted 
using the “Geologic Tops / Horizon Editor” in the “Data Entry/Editors” dropdown menu item (also see Chapter 11 – 
GeoHorizons and the TVD vs. Vertical Section Well Profile). 
 
 

 
ii Created a 1.98 MF file from the Example Log.hxl - easily opened by Windows Photo Gallery and good quality. 
iii Created a 2.38 MB file from the Example Log.hxl - easily opened by Windows Photo Gallery and high quality (better than JPEG).  
iv Created a 46 MB file from the Example Log.hxl - cannot see any reason to use this format. 
v Created a 857 KB file from the Example Log.hxl - opens easily in Windows Explorer or Mozilla Firefox, but low quality. 
vi Created a 1.76 MB file from the Example Log.hxl - opens easily in Windows Explorer or Mozilla Firefox, and high quality. 
vii I (Peter Falk) have personally worked as the well-site geologist on dozens of horizontal wells using four different directional 
companies and never seen another method employed.  
viii It is a good idea to check your numbers with the Directional Driller numbers every few surveys to make positive your numbers 
match. Nine times out of ten any discrepancies will be a simple typographical data entry error. It is usually easy to find the error by 
working backwards to where the derived survey values go from not matching to matching. 
 

                                                           



                                                                                                                                                                                                                        
ix I am thinking of changing that, and allowing images to be added to multiple tracks. Any feedback would be much appreciated. Send your comments to peter.falk@hmgsoftwarellc.com 
x I have kept the preloaded images to a minimum focusing on common images that will be useful to all kinds of situations. It has been my experience that most mudloggers restrict themselves to using only a few choice images for a particular well (fossil fragments or minerals, symbols that represents drilling events like a bit trip). Why have a legend full of images that one never uses? Plus, I have received very little feedback (positive or negative) over the years from clients whether they even look at the accessory images added to a log. Again, if you have strong feelings regarding log images, let me know at peter@horizontalmudlog.com 
xi The size of the image is not the size of the image in the "Add Image" dropdown menu, but the size of the image on the log. A quarter inch height and half inch width corresponds to about 48 X 23 pixels. If using "paint" to create images, make sure that the image is under about 48 pixels for the width and 23 pixels for the height in order to insure that the image is displayed in the log legend.  
xiii Of course, this assumes you have Adobe's PDF Reader or some other PDF viewing software on your computer. To install this free software follow this link: http://get.adobe.com/reader/  


