
Chapter 3 - The File and Formatting Menus 
The "File" menu holds many of the menu items found in all windows programs. The "Format" menu allows the user to 
easily and quickly format their log in a variety of ways. The following chapter discusses some of these features. 

 
The File Menu 
Open and New 
The File->Open selection will open a saved file. Use the File->New (existing log as template)… option to begin a new file 
with the same file formatting as the file presently open.  
Cover Page 
Select File->Cover Page… from the Menu Bar to open the Title Page Editor.  
This editor is used to fill in the title or cover page header that begins every log (see below image) Click the "Import 
Header File" button to load a template cover page, or use the "Export Header File" button to save a template cover 
page. Drag and drop an image to the upper left-hand corner image box with your company logo or any image file (JPEG, 
TIFF, BITMAP, PNG, GIF, etc…) that you desire. Images that are larger than 5" x 3" will automatically be resized to fit, and 
print in the upper left-hand corner of the title page.  
Click on the "Notes" button to open the edit notes window. This is the lower right-hand corner area (red circle) of the 
title page, and is a blank area that can be used for many purposes. For example casing data, or mud data or a short well 
synopsis can be entered in this area (see below). 



 
  Notes Editor      Cover Page 

  
Auto Save Features 

Select File->Auto Save Features… from the menu bar to open the “Automatic 
and Backup Saving Features” window. 
  
There are two features: Automatic Backup and Automatic Save.  
Automatic Backup File Feature 
By default, the "Automatic Backup File Feature" is enabled whenever you start 
a new Horizontal XSection session. The "Automatic Backup File Feature" will 

create a folder called "XSectionBackup" in the same folder that you are saving your Horizontal XSection Log file. The 



"XSectionBackup" folder will contain a backup version (*.hxl) of the file that you are working on. This file will be called 
"BACKUP + file name". For example, if you create a new XSection file called "Lateral1" and save it to "My Documents", 
the Horizontal XSection Log will create a folder called "XSectionBackup" in "My documents" and create a backup of your 
lateral1 file named "BACKUPLateral1".  
Moreover, the backup file will be updated after changes are made to your file. If the program or the computer crashes, 
the backup file will be the most up-to-date file. If you remove either the" XSectionBackup" folder or the "BACKUP + 
filename" file, the Horizontal XSection program will create a new folder and/or file. This creates a handy way of backing 
up your files. The process is to move either the backup file or the XSectionBackup folder to a removable drive, and the 
Horizontal XSection software will create a new one in its place.  
If you use one of the BACKUP files to recover a session, quickly rename the file and move its location. Otherwise 
XSection will create a new XSectionBackup folder in the old XSectionBackup folder with the name BACKUP + filename + 
Backup + filename. This can become confusing fast. The work around is to quickly rename the file in a new location as 
soon as you open the backup file. 
Automatic Save Feature 
The Automatic Save Feature is slightly different. This option, by default, is not enabled when you begin a new XSection 
session. The Automatic Save Feature, when enabled, saves your file before you make new changes to your log. For 
example, if your file is named "lateral1" and located in the "my documents" folder, and you select the "Text" editing 
Mode after just entering lithology beds using the "Lithology" editing mode, XSection will save the "lateral1" file without 
the user being prompted.  
The automatic save feature, when enabled, automatically saves your file whenever you: change editing Modes (i.e. select either Lithology, Text, Add Image, Draw Line, or TVD Log), open the Survey Editor for any lateral, open the Graph Editor for any graph tracks, open the Histogram editor for any of the histogram tracks open any of the formatting menu items, open the "Log Depths…" menu item, open the Log Scale…" menu item, open the Format Lateral Curve Attributes… menu item, open the "Track Positions…" menu item. 
 
Page Setup and Printing 
These menu items are discussed in the Chapter on printing (Chapter 8) 
Export Log as Image (JPEG, TIFF, BMP....) 
The "Export Log as Image (JPEG, TIFF, BMP....) " menu item allows the user to export a complete log (with title page and 
legend) as either a JPEG, TIFF, BITMAP, GIFF or PNG file. Each of the these file types have their advantages, which are 
listed below, file sizes are for average logs: 
JPEG - easily uploaded by photo processing software, ~ 2 MB filei. TIFF - common oil field file type, high quality graphics usually over 2 MB fileii. BITMAP - A great way to fill up your hard drive (euphemism for very large files ~50 MB fileiii). GIFF - small files (usually under 1 MB fileiv), low quality, web browser friendly. PNG - web browser friendly, high quality, ~2mb filev - use this file format to send to your clients if file size is not an issue.  



Export Curve Data as LAS File (*.las)… 
The “Export Curve Data as LAS File (*.las)…” menu item saves all the curve data in all the graphs as a LAS file. Presently, 
data is saved in LAS 2.0 file format. 
The Format Menu 
Log Formatting 
Click on Formatting->Log Depths…, Formatting->Log Scales…, or Formatting->Track Positions… to set the log depths, the 
log scales or the track positions, respectively.  
Formatting Menus 
Each track has its own formatting window, and all follow a similar layout. For example, the below screen example is the format menu for “linear-type” Graph #2 (Formatting->Graph 2 Track->Formatting…). If the graph is set for semi-log, the formatting window looks slightly different.  The format window allows the user to enable or disable the track 

(except the cross-section track which cannot be disabled), set the 
vertical lines, set the horizontal divisions, and set the height 
dimension. The format window also keeps track of the total log 
height in inches, and turns red if the total height exceeds 8". This 
indicates that the total height is too large for landscape printing on 
11" x 8.5" inch paper. Note the program will not stop the user from 
setting a height dimension that is over 8”, rather the red is a 
warning to indicate possible printing problems. 
Histogram Format Menu 
The Histogram Formatting menu has a few added features that 
differentiate it from the other format menus. These added features 
are a "Histogram Name" section, a “Scale” drop down menu, a 

“Divisions” drop down menu, a "Value Properties" section a "Which Way is Up" check box (see below example), and a 
“Factors” section.  
Histogram Name 
This section names the Histogram track. For example if you want the Histogram track to be used for porosity, type in 
"Porosity". Alternately, you could also use the histogram for cleating, grain size, rounding, flare length, directional driller 
ego size, etc. The name the user gives the histogram will be displayed on the histogram track when the log is printed. 
Value versus Factor Mode 
Simply, if the “Factor” text box is set to the value “-999”, the histogram is in values mode and will have the values shown 
in the displayed values text box. Otherwise, the histogram will have a scale dependent on the “Scale” drop down menu 
value multiplied by the “Factor” value. In value mode, the scale drop-down menu is ignored, similarly, in factor mode, 
the “Displayed Values” values are ignored. 
Chapter 9 goes into more detail about the difference between value and factor mode and the histogram 
track in general. 
 



 
Which Way is Up  
This section of the histogram format window sets the direction the histogram will be drawn. Normal (the default setting) 
draws the histogram bottom to top. Check reverse and the program draws the histogram top to bottom. 
    Normal    Reverse 

 
The Graph Tracks 
The graph tracks also have the additional menu item that allows the user to select either a linear or semi-logarithmic 
format.  

 
See "Chapter 4 - Graph Data” for more information on both linear and the semi-log formats and how to edit their 
corresponding scales using the "Graph Data Editors" under the "Data Entry/Editors" main-menu item.  



Formatting the Cross-Section TVD Scales 
From the menu bar, click Formatting->Cross-Section Track->Edit TVD Scales… to open the “Set TVD Scales” window. Each 
scale has three parts: The measured depth (MD) where the scale change begins, the TVD for the top of the scale, and the 
vertical TVD Scale.  
 
These three parameters are set by the user. The vertical TVD scale is limited to the following selections: 50', 100', 200', 
300', 400', 500', 1000', 2000', 3000', or 5000'. The TVD for the bottom of the scale is the TVD top + the vertical TVD scale. 
For example, the highlighted scale change, in the below example, shows a scale change occurring at 4400' MD, with the 
top of cross-section being at 2900' TVD and a 50' vertical TVD scale. Though it is not shown, this would put the bottom 
of the scale at 2950' TVD.  
 
When you load the Horizontal XSection program, it begins with a default TVD scale of 500', set at 1000' MD with the TVD 
top scale set at 1000' TVD. There must always be at least one scale for the cross-section, and the first scale cannot be 
deleted. To change a scale, select the scale from the list of scales on the left, change the TVD Top Depth or the Vertical 
TVD Scale by choosing the appropriate radio button, and click the “Add or Change Scale” button. To create a new scale, 
type in a measured depth value in the text box labeled “Scale at MD” that does not exist in the list of scales. Then 
choose a TVD top value and a vertical scale value, and click the “Add or Change Scale” button. To delete a scale, simply 
select the scale from the list and click the “Delete” button.  
Tip: Do not set a new scale right before or right after a 100' interval (i.e. 2195' MD or 2205' MD), this will result in 
overlap between the new scale text and the MD text values that occur every 100'. It is fine to set a new scale at a 100' 
interval (i.e. 2100' MD). Other safe values are to set the scale at 50' (i.e. 2150' MD). 
 

 
The Effects of Adding a New TVD Scale 
If you create a new TVD scale, or change an 
existing scale, all text blocks, lines, images, TVD 
logs, and lithology beds in the area of the new 
scale, will be affected. However, changes in 
scales affect objects differently. For example, 
lithology beds as well as TVD logs, are 
dependent on the vertical scale of the TVD 
scale. If you change the vertical scale of a TVD 
scale from 200' to 100' (see below picture), all 
lithology beds in the new scale area will become 
twice as large. Moreover, lines will move in 
relation to the new scale. Images and text will 
move their position, but their size will remain 
the same. The location of all elements is 
dependent on the position of the upper left 
corner of each element. A scale change to the 
right of the left-hand corner of an object will 

not move or affect that object.  The below example shows what happens to different objects when the vertical TVD 
scale is changed from 200' to 100'. Notice the anhydrite (orange) lithology bed is not affected by the scale change 
because the left-hand corner of the element is to the left of the scale.  



Before Scale Change      After Scale Change 

 
A common occurrence when adding or changing scales is to move, either on purpose or accidentally, elements out of 
the viewing area (i.e. the sandstone and accompanying text above). The elements still exist in computer memory but are 
no longer visible. Change the scale back and the elements will appear again. It does not hurt anything, other than taking 
up memory, to have elements that are not visible, but if you feel the need to delete elements that are no longer visible, 
use the "Clean-Up Log Utility" in the Tool menu. This utility will delete all elements that are wholly and some elements 
that are partly out of the viewing area. The same is true if you shorten the log length (Formatting->Log Depths…). 
Format Lateral Curve Attributes 
Use this menu item too format the lateral curve attributes like line, width, rotate color, slide colors, etc. This menu items 
is described in more detail in the Chapter "Getting Started" (Chapter 2), and anyway, is self-explanatory. 
 
                                                           
i Created a 1.98 MF file from the Example Log.hxl - easily opened by Windows Photo Gallery and good quality. 
ii Created a 2.38 MB file from the Example Log.hxl - easily opened by Windows Photo Gallery and high quality (better than JPEG).  
iii Created a 46 MB file from the Example Log.hxl - cannot see any reason to use this format. 
iv Created a 857 KB file from the Example Log.hxl - opens easily in Windows Explorer or Mozilla Firefox, but low quality. 
v Created a 1.76 MB file from the Example Log.hxl - opens easily in Windows Explorer or Mozilla Firefox, and high quality. 


