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Chapter 1 – Introduction, Tracks and the Text Editor 
 The HMG Strata Log program is a log drafting program designed for the well-site geologists. With specially designed advanced features, this program is ideal for use on vertical, deviated and horizontal drilling projects, and is a complement to the Horizontal XSection program. Specifically, there are many advanced features to this software designed to help with log correlation on vertical wells, deviated wells and the build portion of horizontal wells.   I advise all users of this software to read through this manual to learn about the many basic and advanced features in the HMG Strata Log Program, but it is remarkably easy to learn and simple to get started.  Easy to Use This software has been designed to be quick to learn, employing many of the standard features typical of PC programs. Most of the popular menu items can also be quickly accessed with the click of the mouse key on the graphical tool bar shown below.  

  
 
Tracks The HMG Strata Log uses the track system to display information. Each track is used to display a particular type of data.  Easy to format, the HMG Strata Log allows for up to 6 separate graph tracks for curves like ROP and gas, 4 separate histogram tracks to display porosity or grain size, a track for sample percentage, a track for descriptions, and a track for depths that can also display other log information. Photographs can be imported (and automatically scaled to fit) into any of the graph tracks or the sample description track (See Chapter 5). Each track has at top a header that displays the tracks purpose (i.e. descriptions). Moreover the graph tracks have a curve key below the header that labels the curves. The track header can be toggled on and off by 



depressing the F2 key. 

 By moving the mouse over a track, information regarding the track is displayed at the bottom of the window. 
 
Advanced Features 
Two of the most advanced features in this program are the ability to toggle between TVD Mode and MD Mode. MD Mode allows the usual measured depth log that has been the industry standard for decades. TVD mode, shown below, allows the user to convert the log into a TVD corrected log (just hit F8 key) with 3 separate scrollable graphs for correlation with offset logs directly on your computer screen, without the hassle of printing. Moreover, correlating tools like the ability to see both subsea and true vertical depths between the mudlog and offset logs and the ability to highlight target zones on offset logs can be very beneficial to help with correlating. See Chapter 9 for more on TVD Mode and Correlating.  The Intervals feature (See Chapter 6 – Intervals Menu) allows the user to shade portions of any or all tracks to show the location of shows, cores, connections, slides or almost any interval of drilling the user would like to highlight graphically.  



  This software has also been adapted to print directly to log paper style printers that are unique with their 8.5” x 6.25” fan fold paper. Header pages and the log key will fit perfectly on these specific page formats.  Finally, this software was designed by a well-site geologist for ease of use and fast data entry. An example is survey data that can be automatically loaded into the text editor by holding down the shift key while clicking the mouse key on the graph or description tracks (see Chapter 4 – Survey Data). Moreover, the survey data to be displayed can be formatted in the tools menu (Tools->Set Survey Data To Text Format…; see Chapter 7).  
 

Tracks: Description, Depth, Stratigraphy and Sample % Tracks 
These tracks are relatively simple and self-explanatory; the graph and histogram tracks will be discussed in later chapters. There is only one of the Description, depth stratigraphy and sample % tracks that can be displayed on the log.  Description Track Click on this track, usually in the middle of the log to open the Text Editor (discussed below). Text will automatically be sized to fill the track. Right click to move text up or down and or to delete a description. Photographs can also be displayed in the description track when in Picture Mode (see Chapter 5 for more information).    Depth Track The Depth Track, also usually towards the center of the log (by default) shows the depth and can be edited to display depths every 100’, 50’ or 25’ in the formatting menu.  Depths are displayed horizontally if the width of the depth track is half an inch or greater, otherwise depths are displayed vertically. Clicking on the depth menu will add the selected image from the Mode->Image Mode menu to the depth track (i.e. midnight image; see chapter 5 for more on the Mode Menu).  



 Stratigraphy Track The stratigraphy track is an interpretive track where the lithology drilled is displayed. To draw lithology in the stratigraphy track simply choose the lithology type from the toolbar then click the left-mouse key while drawing down or up. Lithology will be drawn in 1’ increments. Release the left- mouse key when done drawing. Use the right-mouse key to move or delete a lithology element. Lithology beds can be drawn on top of other lithology beds to show interbedding for example.  % Sample Track The Sample Track is where the geologists enters the quantitative percent values for the rock-type that makes up an individual sample. To open the “Add or Edit Sample Percentages” editor the user simply clicks on the Sample % track.  The sample interval is set in the tools menu item Tools->Set Sample / Histogram Interval (see Chapter 7).  The dropdown menu under Lithology allows the user to select any of the 20 lithology types in the program (see Chapter 7 on how to enter / change lithology types). The drop down menu under Percentages allows the user to select a range from 5% to 100% for the selected lithology. The Percentage Left does the math for you, and you may only leave this window (or select cancel) when the percentage left reads 0%. Use the Load Lithology Order button and / or the Save Lithology buttons to save or load a particular lithology order. The preview area window shows what your selected lithology and percentages will look on the log. Selecting no sample will put a red X over the selected sample depths as shown below. 

 
Text Editor 
All text that is entered in the HMG Strata Log program, including on the Profile and Map Views (see Chapter 7) uses the text editor shown below.  The text editor allows the user to select the Text Color, Font, Background Color, and the Font Size. Moreover, the user can select a Bounding Rectangle and or a Pointer line when text is added to any of the graph tracks. These two features (Bounding Rectangle and Pointer) are not available when the text is entered into the description track. The Set Text Style as Default button allows the user to save the selected Text Color, Background Color, Font and Font Size to memory so that when the text editor is next opened the saved parameters will be automatically selected. The user can also use the F2 – F6 keys to save font parameters (again Text Color, Background Color, Font and Font Size). This utility is an easy way for the user to remember to use a particular text-parameter set for a particular purpose. For example, a log example shown 



 above shows survey data displayed in the graph track using the text color red, font type Arial Black, background color white and font size 8. These parameters can be saved to any of the F2-F6 keys by clicking the particular key button in the Text editor (i.e. key F2). Then next time survey data is imported into the text editor, the user simply needs to press the F2 key. The Bounding Rectangle and the Pointer parameters cannot be saved to any F 2- F6 key or to the Set Text Style as Default feature.  
Note: text parameters set to particular F-keys in the Text Editor, are saved by the program on the particular computer, not to any particular log file. That is, if a particular text-parameters set is saved in the text editor to the F2 key and the log file is saved and the program closed, when the program is reopened by the same computer, the F2 key will have the saved text parameters even if the saved file is not opened. Moreover, if a log file is opened by a different computer, the associated F keys (in this case the F2 key) are not stored in the log file, and so the F2-F6 keys will not have the same text parameters as those on the computer the F keys were set. 
 
 
 
 
Free-30 day Trial 
A 30-day no obligation trial of this software can be obtained by emailing Peter Falk at peter.falk@hmgsoftwarellc.com. 
  



Chapter 2: The File and Formatting Menus 
 
The File menu contains common menu items found in Windows programs as well as HMG Strata Log-specific items. The Formatting menu allows the user to add, remove, and format sections of their log. Chapter 2 discusses these features.  
The File Menu 
 Open and New After opening the HMG Strata Log program on your computer, click on File then Open (Ctrl+O) or use the Open icon in the toolbar. Navigate to a saved HMG Strata Log file (*.vsl) on your computer to open.  To create a New file there are two options; Either open the HMG Strata Log program from your desktop for a blank log with default format, or use File->New (Ctrl+N) from an existing log. Using File->New will preserve formatting and cover page information from the existing log. There is also a New icon in the toolbar.  Cover Page The Cover Page is used to provide useful information about the well such as Well Name, API, and K.B. Elevations that precedes every log. The cover page also contains company info, logo, geologists and sections for notes. 

 Use File->Cover Page (Ctrl+C) to open the “Title Page Editor.” From here, use “Import Header File” to load a template cover page from your computer, or “Export Header File” to save the current Cover Page as a 



template.  To add an image, drag and drop an image file (JPEG, TIFF, PNG, etc.) into the blank region. Images larger than 3”x5” will be automatically re-sized to fit.  There are three sections for “Notes” on the cover page; Notes can be used for general descriptions of the well, project information, or other explanations. Hole Data and Casing Data are handy for keeping track of hole diameters and casing depths. These sections will be shown on printed logs and logs exported as a JPEG, TIFF or other image type (see below).  Save As and Save The File->Save As (Ctrl+ V) and File->Save (Ctrl+ S) menu items function the same as any other Windows program; use Save As to name the HMG Strata Log file and choose a location on your computer, use Save to save your work. Saving often is a good habit. There is also a Save icon in the toolbar.  Auto Save Features Use File->Auto Save Features (Ctrl +A) to open the Automatic and Backup Saving Features window.  By default, the “Automatic Backup File Feature” is enabled when a HMG Strata Log is opened. The Automatic Backup File Feature will create a folder called “HMGStrataLog” in the same folder that you are saving the Strata Log file (from Save As). This “HMGStrataLog” folder will contain a HMG Strata Log (*.hxl) file called “BACKUP+ file name.” This is a backup version of the file you are working on.  Example: If you create a new HMG Strata Log file called “PilotHole1” and save it to “MyDocuments,” the Automatic Backup File Feature will create a folder called “HMGStrataLog” in “MyDocuments,” containing a backup of the PilotHole1 file called “BACKUPPilotHole1.”  The BACKUPfile will be updated after changes are made to the primary file. If the computer crashes or power is lost, the BACKUPfile will be the most up-to-date file of your log. If you remove or relocate the HMGStrataLog folder or the BACKUPfile, the HMG Strata Log program will create a new folder and/or file. This is a useful way to create backups. Simply move the BACKUP file to a removable drive, and HMG Strata Log will create a new backup file in its place.  If a BACKUPfile is used to recover a session, quickly rename the file and move it to your preferred Save As location. Otherwise, the HMG Strata Log will create a backup of the BACKUPfile called “BACKUP+BACKUP+file.” This can get confusing fast- simply rename and relocate the backup file as soon as you open it.  The Automatic Save Feature works differently. This option is not enabled by default when the program is opened. When enabled, the “Automatic Save Feature” saves your HMG Strata Log file before new changes are made. The Automatic Save Feature saves your file automatically whenever you: 



 Open any of the Formatting menu items 
 Select or change Track Specific, Lithology, Image, or TVD Mode (discussed in Ch. 5 & 9) 
 Open Graph Data Editors menu items 
 Open Intervals menu items 
 Open Tools menu items 
 Open the Cover Page window 
 Open the Survey Editor 
 Open the Text Editor  Page Setup and Print Page Setup and Print (Ctrl+ P) are discussed in the chapter about printing (Chapter 8).  Export Log as Image Use File->Export Log as Image (Ctrl+ E) to export the complete log, including Title Page and legend, as a JPEG, TIFF, Bitmap, PNG, or GIFF. 
 JPEG files (*.jpg) are easily uploaded by photo processing software. ~2MB average file size 
 TIFF files (*.tif) are common to oil field, high quality graphics. 2+MB average file size 
 Bitmap files (*.bmp) are very large files, uncommon. ~50MB average 
 PNG files (*.png) are web-browser friendly and high quality. ~2MB average file size 
 GIFF files (*.gif) are small, lower quality, web-browser friendly files. <1MB average file size   Export Curve Data as LAS File Use File->Export Curve Data as LAS File (Ctrl+ L) to save curve data from all graphs as an LAS 2.0 file (*.las). This will export ROP, Gas, Gamma, and other graph information, along with Cover Page information. 

TVD Data in the LAS File In TVD Mode (See Chapter 9) the Export Curve Data as LAS File feature will add a TVD column to the LAS File. 
  Export Lithology Percent Use File->Export Lithology Percent to save lithology percentages from Sample % track as a Text File (*.txt) or Comma Delimited (*.csv) file.  Exit File-> Exit (Ctrl+ X) will close the HMG Strata Log program. The program will ask if you want to save before exiting if changes have been made.   
 
The Formatting Menu 
The Formatting menu in HMG Strata Log controls the layout, appearance, and contents of the log. The Formatting menu also controls the dimensions of each element, allowing customization per client request and printing considerations.  
Log depths, Log scales, and Track Positions Use Formatting-> Log depths to set start and end depths for your HMG Strata Log. 



Use Formatting-> Log scales to set the scale of the log; choose from Imperial or Metric units with several scales available for each. Use Formatting-> Track Positions to re-arrange the position of tracks according to specific use or preference.  Track Formatting Except Histogram Each track has its own formatting window, and all are similar in layout. Use Formatting->(x) Track->Formatting to open the formatting window for the selected track.  The first check-box will enable or disable that track on your log. The formatting window for each track will allow changes such as number and type of divisions, total track width, and other options. The format windows keep track of total log width. If the total log width number is red, the log is wider than 7.5 inches, indicating log width is too large for printing on standard 8.5x11” pages.  The graph tracks have an option to choose linear or semi-log for displaying graph data. See Chapter 3 for more about graph data.  
Histogram Track Formatting 
The histogram tracks have format windows which allow further customization. For instance, the Grain Size histogram tracks are preset with four grain size options, but allow changes (including track name) if you want to use the track for another feature, like oil fluorescence or degree of roundness.  If “Factor” is set to -999, the histogram is in “Values mode” and will display the values which are set (v. f, fn, etc.). If the “Factor” is set to another number, the histogram is in “Factor mode” and will display the “Scale” drop-down menu value multiplied by the “Factor” value.  Value versus Factor Mode Simply put, if the “Factor” text box is set to the value “-999”, the histogram is in values mode and will have the values shown in the displayed values text box. Otherwise, the histogram will have a scale dependent on the “Scale” drop down menu value multiplied by the “Factor” value. In value mode, the scale drop-down menu is ignored, similarly, in factor mode, the “Displayed Values” values are ignored.  Values mode When the program is started, all three available histogram tracks are, by default, in values mode.  The 



histogram values must be input by the geologist / user in the “Displayed Values” area. The values need to be separated by commas (comma delimited). For example, if the user enters the values “6%,12%,18%,24%” (there is no need to put in spaces between values), the histogram track will have five values: none, 6%, 12%, 18%,and 24% (i.e. vales for a porosity histogram). Another example would be to enter: “trace,fair,poor,good,v.good,excellent”.  This would translate to a histogram with the values: none, trace, fair, poor, good, v.good, and excellent (i.e. oil show histogram).  “None” does not need to be entered as a “Displayed Value”, it is added to the histogram by default as a 0 value.  When in values mode, the “Scale:” drop-down menu box will be ignored. In values mode the scale of the histogram is always set by the number of values separated by commas plus the “none” value. The “Visible Divisions:” drop-down menu box is still used in values mode for selecting the number of vertical divisions for the particular histogram track. The below figure shows a portion of a histogram formatting editor set for values mode, with the Factor box set to -999, and the values of the histogram being set to 6%, 12%, 18%, and 24%.  

  Factor mode The histogram is in “Factor” mode when the “Factor” value is set to any decimal value other than ‘-999’. When in “Factor” mode, the “Displayed Values:”, used in “Values” mode are ignored by the program.  The basic procedure for using the histogram in factor mode is to pick a scale using the “Scale:” drop-down menu. Any scale from 2 through 20 can be selected (in the previous version, the histogram scale was immutable, set at 10). After a scale is selected, the user inputs a “Factor” value, which can be any decimal number.  The program computes the histogram values to be selected by the user by multiplying each scale by the factor.  In the below example, the scale is set at 20, with a factor of 5. This means that the histogram values for the % Cavings Histogram will be: 0, 5, 10, 15….90, 95, 100. When the user clicks on the % Cavings histogram track, they will be presented with a drop-down menu with the above just mentioned values as shown below.  Histogram Direction The histogram can be formatted to draw Left to Right (default) or Right to Left (see below formatting window) 



  Adding Histogram Data to the Histogram Track Similar to the sample track, the user can add data to the histogram track by simply clicking on the histogram track near where they want the data to go. This will open the histogram track editor allowing the user to edit the depth interval and the value of the histogram  Click and Drag Histogram values may also be drawn using the mouse. Hold down the shift key and draw in the interval and value of the histogram. When the left mouse key is released, the histogram editor will open with the depth intervals and histogram values filled in based on the click and drag position.  
  



Chapter 3: Graph Data 
 HMG Strata Log has graph tracks, up to six, which are used to display data in graph format. Typical types are drilling data, gas data, or MWD/LWD data. There are several methods to load and edit the data for display on the log.  
Graph Data Editors  
 
The Graph Data Editors menu, located at the top of the HMG Strata Log window will open the editor for each graph. The Graph Editor windows can also be opened using the graph symbols on the top right side of the HMG Strata Log tool bar. Graphs #1 and #2 are enabled by default, use the Formatting menu (Chapter 2) to enable Graphs 3-6.      The Graph Data Editor window for each graph is divided into “Edit Curve Attributes” and “Import / Export Graph Data.”  

  Edit Curve Attributes The Edit Curve Attributes section of the Graph Data Editor window allows changes to Curve Name, Curve Units, Curve Scales, Line Style, and Numeric Data.  To edit a curve attribute for the selected graph, first click on the curve you'd like to edit from the list at the top right corner. To replace the current name or scale units with new name or units, type in the corresponding text box then click “Change Name” or “Change Units.”  Use the Line Style drop-downs to change the appearance for the selected curve.  To add or change scales at certain depths, use the “MD:” text box for starting depth, then click “Add New Scale.” Highlight a curve in the “Curve Scales” box to change Left/Right values. Use “Delete Scale” to remove the selected scale from the curve (be careful, there is no undo for deleted scales). Scale changes are useful to display graph data with wide ranges, such as gas ppm where large gas shows are encountered.  



Edit Numeric Data will open a window for the selected curve, which allows manual editing of imported data if there are missing, incorrect, or undesired data.  Delete Curve Data will completely delete the data in a selected curve, after prompting “Are you sure?” 

 Editing Numeric Data Most data will be imported into the log graphs from text (*.txt) or LAS (*.las) files, but sometimes it is necessary or simpler to edit and enter the data directly using the “Edit Numeric Data” function. From the Graph Data Editors menu, select the correct graph, then select the curve you'd like to edit numeric data in. Use the table to edit the data as desired (just click on an existing value and type new value). “Insert Row” will add a row below the highlighted cell with corresponding depth (MD) increase and datum. “Delete Row” will remove the selected row and its datum. “Check Sorting” will check for out of order depths in the MD column. Use the “Datum Column” functions to delete or replace all data values with a particular, user-set value.  
Import / Export Graph Data 
 
Importing and exporting graph data is a key feature of HMG Strata Log. Importing data is the easiest and quickest way to display ROP, Gamma, Gas, etc. on the log. HMG Strata Log will accept text files (*.txt), comma separated files (*.csv), and Log ASCII Standard (LAS) files (*.las).  Text files are easy to create and edit using Notepad. Comma separated files can be opened and edited in Microsoft Excel (good for editing large amounts of data). The LAS file format is common in the oil and gas industry, used for MWD/LWD data, directional data, and data from an EDR (i.e. Pason or TOTCO).  



 

  Importing Data To Import Data, first open the Graph Data Editor. Then select the “All Depths” bullet to overwrite existing curve data or the “Some Depths” bullet if specific sections of imported data are needed. Then, click “Import Graph Data File,” find the file to be imported on your computer, and click open. A “Graph Import” window will open with drop-downs according to specified curves on the graph track.   By default, the program will use column 1 from the imported file as MD (can be changed if needed). The other curves require the user to select the correct column from the imported file. An advantage of LAS files is that the columns are usually named to describe the data (GRC, ROP, or Total Gas, for instance).  When the appropriate columns have been selected for the chosen curves, click “Load File,” then “All Done”. The Graph Import window will remember which columns were selected the next time data is imported.  The “Reject upload if out-of-order depths” box is automatically checked and will reject files with out-of-order or duplicated MD values. Disabling this feature may allow errors in curve data, but these can be corrected later from the Edit Numeric Data menu (see above).  Overwriting Data When data is loaded for a curve that already has data, it will overwrite depths that overlap. If Graph #1 already has ROP data from 1000-2000' MD and a file is imported with ROP data from 1500-2500' MD, Graph #1 will then show data from 1000-2500' MD. But, if another imported file contains data from 1000-1500' MD, the section from 1500'-2500' MD will be deleted. These features make it simple to add data for sidetracks without deleting data by hand, overwrite errors in curve data with a corrected file, and import curve data in smaller sections that build on each other. 



 Linear or Semi-Log Scales The graph tracks can employ either linear or semi-logarithmic scales. The selection is made using the formatting menu (see Chapter 2). The linear scale option allows for more customization of the log scale. Each curve may have a different scale, and scales can be changed numerous times for each curve. Also, left and right values can be changed and curve wrap can be enabled or disabled.  A graph with a semi-log scale has fewer options. The semi-log scale is useful for displaying curves with a wide range of values (i.e. Total Gas units and Gas Chromatograph ppm data). Semi-log scales always have a minimum value of 1. Maximum values are set in the graph editor and can range from 100 to 1,000,000. The direction of the semi-log scale is either normal (higher values to the right), or reverse (higher values to the left). All curves share the same scale minimum and maximum values and only one scale is possible for a semi-log graph track.  
Exporting Data 
HMG Strata Log will export individual graph curve data as text files (*.txt), or comma separated files (*.csv). The Export Curve Data (Ctrl+ L) function (see Chapter 2) will export all curve data from the log as a Log ASCII Standard (*.las) file.    



Chapter 4: Survey Data 
 HMG Strata Log uses survey data for several purposes. Survey data can be easily displayed along the log for information purposes. Survey data can also be exported as a file for sharing. Importantly, survey data inputs allow HMG Strata Log to correct log data (depths, gamma, gas, etc.) for true vertical depth (TVD) when the well is being drilled directionally. See Chapter 9 for TVD Mode and correlating. Chapter 4 will discuss how to enter, edit, import, export, and use survey data in the HMG Strata Log.  Abbreviations and Terms: 

MD Measured depth 
INC Inclination of the survey tool, where 0° is vertical and 90° is horizontal. 
AZ Azimuth of the survey tool, corrected for magnetic declination. (0°-360°) 
TVD True vertical depth – vertical distance from KB (kelly bushing) to survey tool, also called KBTVD 
VS Vertical section – the horizontal distance from surface hole location to the survey tool. Measured along azimuth from surface hole to planned TD target position. 
NS North/South – the map-view N/S coordinate for survey tool. Also called Northings, + values are North of surface hole location, - values are South. 
EW East/West – the map-view E/W coordinate for survey tool. Also called Eastings, + values are East of surface hole location, - values are West. 
DLS Dogleg°/ 100' – degree of curvature of well bore measured in degrees per 100' measured depth. 

The MD, INC, and AZ are measured by survey tool and MWD personnel; TVD, VS, NS, EW, and DLS are derived survey values. Most directional companies, and HMG Strata Log, use the Minimum Curvature method to derive these values.            
Survey Editor 
To open the Survey Editor use Tools->Survey Editor. There is also a Survey icon in the toolbar, located near the Graph Data icons. This will open the Borehole Survey Data Sheet. A Tie-In Survey is necessary to begin the curve, then surveys can be added one at a time using “Add Survey” button, or multiple surveys can be imported as a *.csv file using the “Import Survey” button.     



                       Adding Surveys The first step in adding surveys one at a time is the Tie-In survey. Go to Tools->Survey Editor. Then, at the top of the Borehole Survey Data Sheet, click Edit/Add Tie-In Survey. This is the survey from which all subsequent survey values will be based. Often the directional company will provide this, or use the first available survey. The Direction value is important; this allows HMG Strata Log to calculate the Vertical Section accurately. Again, the directional company will be able to provide a Direction or Vertical Section Along Azimuth value.  After the Tie-In survey is added, use the Add Survey button to add surveys one at a time. Input the MD, INC, and AZ, then click Done. HMG Strata Log will calculate the remaining survey values.  To Edit or Delete a survey, highlight the survey you'd like to change or remove, and click the corresponding button.  Matching the Directional Drillers' Values Though there are other methods for computation of the derived survey values, the most common method on horizontal wells is the minimum curvature method. As long as the directional company is using this method, the values derived from the HMG Strata Log software will match the values from the directional driller. At times rounding differences will result in values that differ by a few hundredths. If values differ by more than a few hundredths, examine your MD, INC, and AZ as well as the tie-in survey for data entry errors. Also remember that sometimes DD and MWD hands make mistakes too (though they may deny it).  



           Importing Surveys Formatting *.csv file to be imported into the survey editor is simple. Cell A1 is used for Direction, or Vertical Section along Azimuth (surface hole location to bottom hole location.) B1 is simply “Direction”. Row 2 is used as header for the survey columns. Row 3 holds the Tie-In value. Rows 4 and onward are used for survey parameters MD, INC, and AZ. The other columns (TVD, VS, NS, EW, and DLS) will be calculated by HMG Strata Log when the survey .csv file is imported. See the above example for proper formatting of the survey file to be imported. After the file is formatted and all available or desired values are added, be sure to save the file as a *.csv (comma delimited). Close the spreadsheet file before using the Import Survey function. Importing a .csv file will delete and replace previous values, including the Tie-In.  To export the survey values which have been added to the Survey Editor as a *.csv file, just click the Export Survey button and save it to your computer.   
Displaying Survey Data on your Log 
Once the survey data has been entered into the program, displaying the survey data on your log is as easy as a click of the mouse key. The first step is to set the survey data to text format.  
 
 
 
 
Set Survey Data To Text Format 
The Tools->Set Survey Data To Text Format item will open a simple window which allows the user to choose which survey parameters will be added to the log as text. As shown to the left, select the parameters you want to display including if you want a bounding rectangle and a survey title. 



 
 
 
 
 
 
 
 
 
 
 
 
 
Displaying Survey Data with a Click of the Mouse 
Survey data can be displayed on the description track and any of the graph tracks. After surveys have been added to the survey editor, and Surveys to Text Format has been set to your liking, just hold the “Shift” key and click on the log Graph 1 track at or near the MD of the survey you want to display. The text editor will then open with the survey data entered. A survey marker at the correct depth will also be shown on the depth track (shown below). 



 
  



Chapter 5: The Mode Menu 
 

The Mode Menu 
The Mode menu, located in the menu bar at the top of the HMG Strata Log window, is used to switch between modes for different actions and functions.   Track Specific Mode The Track Specific Mode (F1) is used for most mouse actions within the log. The mouse acts differently in Track-specific mode for the different tracks. When the mouse is clicked, text is added to the description and graph tracks, the % sample editor is opened in the Sample % track, the histogram values editor is opened in the histogram tracks, lithology is drawn in the stratigraphy track and images are added to the depth track.  Image Mode The Image Mode is used to add symbols and images to the log, such as midnight, connection, oil show, bit trip, fossils, minerals, or custom images. Images can be added to the Sample %, Depth, and Stratigraphy tracks. To add an image, use Mode->Image Mode, and choose a symbol. To place it on the log, left click at the point you'd like to add it. Right click to move or delete it. You must be in Image mode to add images to the histogram, Sample % and stratigraphy tracks. 



 
Picture Mode The Picture Mode is used to add JPEG (*.jpg), TIFF (*.tif), or Bitmap (*.bmp) files, such as microscope photos, to the log. Pictures can be added to the Descriptions track and Graph tracks 1, 2, 3, and 4. Pictures will be automatically resized to fit within the track they are added to, so there is no need to modify picture size before adding them to the log.  Adding a Picture To add a picture, use Mode->Picture Mode. Then, click where you want the picture added, navigate to the saved picture on your computer, and click Open.  
 
 
Importing Images 
It is easy to import images into HMG Strata Log. To add or remove images from the Image mode menu, use Mode->Image Mode-> Add/Remove Image(s). This will open a new window where default images can be removed and new or custom images can be imported.   To import a new image, click Import Image button. Then navigate to a saved bitmap (*.bmp), JPEG (*.jpg), or TIFF (*.tif) image, on your computer. After you have opened the image file, the log will ask for a name. The name and image will be displayed in the Image Mode dropdown, and on the log legend when printed. Notes about importing images: 

 Set Max Dimension dropdown will automatically resize images that are larger than the chosen value. 
 Images will not be rescaled when track dimensions are changed. 
 If the Horizontal XSection program is also installed on your computer, it will create a folder called “XSection Utilities” in the “Documents” section of the computer. This folder contains some additional images which may be useful. 
 Microsoft Paint is an easy way to create and save new symbols, see section below.  To remove an image, just highlight it in the list and click Delete Selected Image button. Images can be removed from the Image Mode list, but will still appear on the log legend when printed. See Chapter 8 for more on Printing.  

Creating Custom Images with Microsoft Paint 
Images are simple to create using Microsoft Paint. Paint is a standard program on Windows operating systems (although hard to locate on Windows 8- use the “search” function). To create a custom symbol, first open the Paint program, then, in the Properties toolbar menu, set the width and height.  

 16 x 16 pixels is recommended, but symbols can be larger or smaller. Images will be distorted to fit in the Image Mode dropdown, but will be full-size on the log.  



After setting the image dimensions, zoom in as far as necessary, then start creating a custom image. When the image is complete, save it as a bitmap (*.bmp - recommended), JPEG (*.jpg), or TIFF (*.tif). Import it into your log using steps outlined in Importing Images in the above section.  
Toggle TVD Mode 
Toggle TVD Mode (F8) will alternate between the standard, MD-scaled log, and the TVD-corrected TVD Mode. TVD Mode is used for correlating gamma or other MWD/LWD/wireline log data from the current well to nearby offset wells. TVD Mode requires survey data to be entered, for more about TVD Mode see Chapter 4 on Surveys and Chapter 9 on TVD Mode.  



Chapter 6: The Intervals Menu 
 

The Intervals Menu 
The Intervals Menu item is a tool that allows the user to selectively ‘shade’ intervals, either by partial, whole, or multiple tracks. This tool, as the example below shows, can be used to display formation tops across the whole log, connections in the depth column, slide intervals where ROP may be decreased, and other features. The below examples will show how to use some of the default intervals installed with the program, how to change formats of intervals, and how to create your own intervals.   Default Intervals For the well-site geologist, one of the most useful Intervals menu item is Tops. Tops are used to mark contacts between geologic units. To add a Top to the log, use Intervals->Tops. This will open a window which allows tops to be added as necessary. Use Add/Insert Row button to add as many rows as needed (or one at a time), then click in the StartDepth column and type a value. In the EndDepth column, type a value larger than starting depth; x + 0.7 works well for a 5-inch (1:240) log. Then click ‘Done’, and the new top interval will appear across the log as a red line (shown below).    



 

  To add Connections, the process is similar: go to Intervals->Connections, and enter values corresponding to pipe tally or connection depth, then click Done. This will create a small green marker at the specified depth within the Depth track (the default track for connections but easily changed by the user). By default, the Connection intervals are displayed as 20% of the depth track. To add the green “C” connection symbol (see above image), use Mode->Image Mode->Connections and left-click in the Depth track. To change how the interval is represented, see section on Format Intervals later in this chapter.  



           To add Slide intervals, go to Intervals->Slide. Click Add/Insert Row button a few times to add spaces, then click within StartDepth and EndDepth spaces and input the depth intervals for each slide. The slides will be displayed on the log as a shaded pale red region within the Graph 1 track, as shown at right.

 



   To add intervals for Planned Cores and Recovered Cores, follow the same steps. Go to Intervals->Core, click Add/Insert Row button several times, and input starting 



and ending depths for a planned core. The default will represent the interval as 50% of the Graph 1 width shaded light green. Then, after the core has been recovered (and commonly a few feet are missing) go to Intervals->Recovered Core and input start and end depths for the recovered core interval. Click Done, and these intervals will be represented on the log as shaded purple in the other 50% of Graph 1.  Formatting Intervals / Adding Custom Intervals It is easy to change how intervals are represented in HMG Strata Log. You can quickly change the name for an Interval menu item, change the color, or change which tracks it is displayed in. Just go to Intervals->Format Intervals and it will open the window shown to the right.  Here, the highlighted interval is named “Core”, is represented only on the Graph 1 track from 0 to 50% of track width, and is a Light Green color. But it is simple to add the same Core intervals into the Graph 2 track- just click the check-box on the left side of window. Or you could change the name from “Core” to “Planned Core Sample # A18-9c” by highlighting the interval, clicking in the Interval Name space, typing the new name, and click the New Name button. In this manner, the default intervals in HMG Strata Log can be modified to suit a variety of purposes.  A new, custom Interval can be added by clicking the Add button under the Intervals list. Say you want to add an interval to represent downtime gas and that is shown across the middle of Depth, Porosity, Oil Show and Graph 



2 tracks- easy!  Click Add button, and a New Interval item will appear in the intervals list. Highlight it, then type a new name in the space and click New Name button. Uncheck the Graph 1 box, and check the others you want to add. Change the color using the dropdown, and set the extent within each track using Interval Width spaces. Click Done on the Intervals Editor window, and your new interval item is ready to use. You can add the new intervals by clicking Intervals->down time gas, add some rows and enter start/end depths, just like the default intervals discussed previously.    



Chapter 7: Tools and Views 
 

The Tools Menu 
 
The Tools menu contains several items which accomplish various useful tasks in the HMG Strata Log program. In the Tools menu are options to edit lithology images, set sample intervals, correct or modify depths, expand lithology toolbar images, clean-up the log, and input surveys. Surveys are discussed further in Chapter 4.  Lithology Editor The Tools->Open Lithology Editor will open a new window: The Lithology Editor window will allow you to add, change, or delete the lithology symbols used by HMG Strata Log. The lithology list is preset to include rock types as shown to below right. However, changes are simple.  To change the name of a lithology, just select it from the list, type a new name in the text box, and click “New Name” button. (i.e. changing “Sandstone” to “Arenite”)  To change the image, highlight the lithology to edit and click “Change Image” button. Then navigate to a saved bitmap (*.bmp) image on your computer.   
Creating Custom Patterns with 
Microsoft Paint 
Bitmap files are simple to create using Microsoft Paint. Paint is a standard program on Windows operating systems (although hard to locate on Windows 8- use the “search” function). To create a custom lithology image/symbol, first open the Paint program. Then, in the Image toolbar menu, set the width and height. 16X32 pixels is recommended. After setting the image dimensions, zoom in as far as necessary. This will make it easier to design your pattern. When you are done creating your lithology image is complete, save the image as a bitmap (*.bmp). An alternative method is to modify an existing image by right-clicking a bitmap file, then "open with" and select "Paint" program from the list of programs. See the Chapter _ section on Image Mode for more about creating and editing images for HMG Strata Log.  



The Lithology Library 
If the Horizontal XSection program is also installed on your computer, it will create a folder called “XSection Utilities” in the “Documents” section of the computer. This folder contains some additional images, lithology symbols, and lithology libraries which may be useful. The lithology library import and export buttons are a way to import and export a complete library of custom patterns. Only import a lithology library at the beginning of a log session, before any lithology beds have been placed on the log, or sample percentages entered in the "Sample % Track". When a lithology library is imported, all existing lithology beds in the "Stratigraphy Track" and samples in the "Sample % Track" are deleted. A lithology library can be exported at any time. Personalized lithology patterns in a log are saved with the log. However, it is suggested that you use the export lithology library function to backup your custom lithology patterns.  
Other Tools 
 Set Sample/Histogram Interval Tools->Set Sample / Histogram Interval will edit the interval (10’ samples, 20’ samples, etc.) for Sample % and Histogram tracks.         Depth Correction Utility Tools->Depth Correction Utility will allow corrections to depth if, for instance, a tally error is discovered and a correction is necessary. The entire log can be shifted up or down, or just one section can be adjusted. It's a good idea to Save the log (Ctrl+ S) before making a          depth correction, just in case.  Expand ToolBar Buttons 



Tools->Expand ToolBar Buttons will expand the lithology symbols to their correct dimensions. The default dimensions are condensed to save space on the tool bar.  Clean-Up Log Utility Tools->Clean-Up Log Utility is a neat tool that will delete images, symbols, text, data, etc. that are outside of the visible log depths. For example, if you made log starting at 500' MD and ending at 5000' MD, then later realized you only needed 1000-4200' MD, it is simple to change the log depths (Formatting->Log Depths). However, the program will keep the data, text and images from the original 500-5000' MD range. To permanently remove the text, stratigraphy, intervals, images, histogram data and sample percentages outside of the currently visible area, use Tools->Clean-Up Log Utility->Yes/No.   Survey Editor and Set Survey Data To Text Format tools are discussed in Chapter 4. 
 
The Views Menu 
The Views Menu contains a Plan /Map View and a TVD vs. Vertical Section view. HMG Strata Log will automatically create these views when survey data is entered. (See Chapter 4: Surveys)  Plan View / Map View  



  The Plan / Map View will use survey data to display the well bore. If the well bore is vertical, map view won't be very useful, but for a deviated hole it can be helpful. Use Map Scale menu item to change X and Y scales. Use Set SHL Map Position to adjust where the surface hole location is represented within the Map View window. The Plan / Map View can be printed or exported in several image types (JPEG, TIFF etc). Hard lines can be entered as footage from the SHL and text can be entered by clicking the mouse key within the Map View window.  Profile View The TVD vs. Vertical Section view will use survey data to display the well bore from a “side view”. Here, it is necessary to know the “vertical section along azimuth” direction for the view to be displayed correctly. See Chapter 4: Surveys for more about tie-in values and surveys. 



   Use Scales menu item to adjust TVD and Vertical Section scales if the borehole is not displayed completely. The TVD vs. Vertical Section view can be printed or exported in several image formats (i.e. JPEG, TIFF, etc.). As in the Plan / Map View, text can easily be entered and displayed by clicking the mouse key to open the text editor.      



Chapter 8: Printing 
 

 
Page Setup 
The first step in the printing process is to choose either 8.5” x 11” Letter or 8.5” x 6.25” Fan-Fold Log under 
File->Page Setup. The Letter size will print the HMG Strata Log on standard printer paper, the Fan-Fold option 
will print a continuous log onto standard log-style paper. 
 

  
 
 
After choosing the appropriate page setup, the Pages to Print window will appear. Use check boxes to include 
or omit the Title Page and Legend from the printing process, choose Print All Depths or Select Depths to only  
 
 
 
 
 
 
 



 
 
 

  
print a particular section of the log, and whether to Scale to Page. Note, images and pictures embedded in the 
log and are not scaled. Clicking “Ok” will bring up the Page Setup window.  
 
 
 
By default, the page orientation will be set to Portrait, and top and bottom margins are set to zero. This will 
print a log which is continuous and/or uses the fewest pages. The left and right margins are set by the program 
to center the log within the printed page. 
 
If the log is too wide to fit on the printed page, a warning message will appear. Either reduce the total log width 
(See Chapter 2: File and Formatting), or use the Scale to Page option in “Pages to Print” window.  Scale to Page 
Scale to Page will print an accurate log if total log width is greater or less than paper size, but it is 
recommended to keep the total log width at 7.75-8.0” when using 8.5” wide paper. The Scale to Page feature 
will rescale all enabled Tracks so total width is 8.0”, text and image locations will be moved accordingly. 
However, text and image size will not be rescaled, so use Scale to Page carefully. 
 
Printing 
Once Page Setup is complete, the log can be printed using File->Print (Ctrl+ P) or using the print icon in the 
toolbar. A Print window will appear, select appropriate printer device and select banner printing if applicable. 
 



 
 
 
 
 
 
 
Printing a PDF file 
HMG Strata Log does not currently have a print preview feature, but printing a PDF log is an easy way to 
preview the printed log. Install a PDF printer on to your computer. Then select it from the list of available 
printers when the log is ready to print. This will create a PDF file of your log that is exactly the same as if you 
had printed the log to paper. Use the PDF to proofread, determine total page length, or easily send the PDF log 
file to clients. 
 
 
Two PDF printers that I have had good luck with are CutePDF (www.cutepdf.com) and bullzip PDF 
(www.bullzip.com). There are many sites that allow you to download either of these PDF printers, but be 
careful because many of these “free download” sites will also install a bunch of stuff onto your computer that 
you won’t need. To be safe, download from the above mentioned URL’s. 
   



Chapter 9: TVD Mode 
 
Overview 
HMG Strata Log has a TVD Mode, which converts a regular measured depth log into a true vertical depth log using the available survey data. Moreover, it opens three separately scrollable graph tracks to import offset logs for correlation purposes. To convert the log to TVD mode go to the Mode Menu and click on Toggle TVD Mode. To use TVD Mode, there must be at least two surveys entered (see Chapter 4). Many of the regular log-editing features are disabled when in TVD Mode. 

   
Loading Offset Graph Data 
Offset graph data curves can only be entered into the offset graphs when in TVD Mode (Mode->Toggle TVD Mode or F8). Click Graph Data Editors->TVD/Offset Graph #x->Load Log Data. Entering the log data for the offset graphs is very similar to the regular graph tracks (see Chapter 3).     



Click Import Graph Data File, and find the gamma, resistivity, bulk density, or other wireline/LWD data file (*.las format recommended, but *.txt and *.csv also work) you're interested in from the offset well. After selecting a file, the Graph Import Editor window will open. Use the dropdowns to select a data column for each curve then click Load File. You can change the names of curves in the same manner as other graph curves in HMG Strata Log (see Chapter 3). Just highlight the curve to edit, type a new name and click Change Name. Once the data are imported, you can also change the scale and the line style. Finally, click All Done from the TVD/Offset Graph Data Editor window.                        Each Offset Graph also has a Set Start/End/KB Depths option. Start Log at Depth and End Log at Depth will simply trim or expand the offset graph to the specified depths. Log KB Elevation is important because it will determine correct SS (Sub-Sea) depths when correlating.      



 
Highlight Mode and Text Mode 
In TVD Mode, the Mode menu at the top of the window contains three items: Text Mode, Highlight Mode, and Toggle TVD Mode.  Text Mode 

  Text Mode will create notes and text within the Offset Graphs. Just click where on the Offset Graph you want to enter text and a text window will appear. The text can be used to label tops, interesting features, well parameters, etc. for the offset graph. While in TVD Mode, text can only be added to the offset graphs. To add text to the main portion of the log, the user will need to Toggle TVD Mode (F8) to MD Mode.  Highlight Mode 

  Highlight Mode will make highlighted sections on the Offset Graph. This is useful for denoting tops and unique signatures that are helpful when correlating. To highlight a section in TVD Mode, go to Mode->Highlight Mode and just click and drag over the section you'd like to highlight. Again, highlighting can only be added to the offset graphs in TVD Mode. To add tops or similar markers to the main log, use the Intervals menu (see Chapter 6).  
Correlating with Red Line 
After data have been added to the TVD/Offset Graph(s) and the Graph 2 track on the main log (see Chapter 3), correlating between them is easy. Click in the main log area to add a red line. This line shows TVD and SS depths for each track in black and red numbers, respectively, above and below the red line. Then, find a distinctive gamma or (other curve) peak on each graph and line them up using the separate scroll bars and depth markers for each offset graph. After the graphs are lined up, you can scroll all of them at once by holding Shift and using the main scroll bar on the far right, or use F9 to lock the scroll bars. TVD Mode is very useful when you have offset graph data from a nearby well with geologic tops highlighted and labeled. Then, as MWD/LWD data is available for the Graph 2 track, the same tops can be found and recorded. 



  Note: If MWD/LWD data extend beyond the last input survey (i.e. using near-bit gamma tool), the TVD corrected log will interpolate depths based on the last available survey. This is not a big deal at low or unchanging inclinations. But for the most accurate TVD depths at dynamic inclinations (i.e. during build/curve section), it is necessary add projected surveys for a more accurate TVD log.  
Scroll bars, Scroll Lock and the F9 key in TVD Mode 
Once data have been added to the Graph 2 Track and at least one TVD/Offset Graph, the tracks can be scrolled individually or all at once in TVD Mode. To scroll each track individually, there are 4 scroll bars in TVD Mode, shown below. The main scroll bar is on the far right of the screen and will control the main portion of the log. The offset tracks are controlled with the other three scroll bars. 



To scroll all of the tracks together, hold the Shift key down and use the main scroll bar. This will move the main log and all 3 offset tracks as one. Alternatively, press the F9 key to “lock” the scroll bars. The status bar at the base will show “TVD Log” or “TVD (Scrolls Locked)”. When the scrolls are locked, the offset tracks can still be scrolled individually, but using the main scroll bar will move everything together. Press F9 again to unlock the scroll bars, where each track will move independently. 

Special Features of TVD Mode 
 TVD mode has some special features.  Omitted Text Items Because a TVD log will condense much of the MD log data as your inclination increases, long text paragraphs will not be displayed when the log is toggled from MD Mode to TVD Mode. For example, a description in the description track that is more than a few sentences will not be displayed. Short text items, like formation tops, will be displayed. In the example below the TVD Mode log shows the tops and the depths of the target and formation markers, but no descriptions. That is because the longer descriptions did not meet the short length criteria to be displayed on the TVD log. That way a TVD log will not become unreadable because of overlapping text items.   LAS Files LAS files that are exported using the menu item File->Export Curve Data as LAS File (*.las) when in TVD mode will have a column for MD and an additional column for TVD. When in MD mode the exported LAS file will only contain the MD value.  


